UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor turcant
Visitor
347 Views
Registered: ‎07-27-2018

Master AXI interface doesn't appear in address editor

Jump to solution

Hi everyone,

I'm working on ZCU102 with Vivado 2017.4

I'm using a custom IP in a bloc design. This IP has 2 AXI4 master interfaces I connect through the AXI interconnect to DDR4 MIG.

In the Address editor window, only the interface of the zynqMP appears. Why ? How to get my IP in this window ? Is the connection available anyway, with the same addresses as for the zynqMP ?

Thank you

AddressEditor.PNG

0 Kudos
1 Solution

Accepted Solutions
Visitor turcant
Visitor
278 Views
Registered: ‎07-27-2018

Re: Master AXI interface doesn't appear in address editor

Jump to solution

Ok I figured it out.

When I packaged the IP, I didn't add an address block in "Addressing and Memory". That's why the IP didn't appear in Address Editor

3 Replies
Voyager
Voyager
323 Views
Registered: ‎02-01-2013

Re: Master AXI interface doesn't appear in address editor

Jump to solution

It would help if you also showed your block diagram...

 

0 Kudos
Visitor turcant
Visitor
288 Views
Registered: ‎07-27-2018

Re: Master AXI interface doesn't appear in address editor

Jump to solution

Hi, 

There is a view of the diagram (only the interfaces are shown, but clocks, reset and else are connected).

Diagram.PNG

0 Kudos
Visitor turcant
Visitor
279 Views
Registered: ‎07-27-2018

Re: Master AXI interface doesn't appear in address editor

Jump to solution

Ok I figured it out.

When I packaged the IP, I didn't add an address block in "Addressing and Memory". That's why the IP didn't appear in Address Editor