cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
7,082 Views
Registered: ‎07-26-2013

Ultrascale Transceivers wizard not allowing QPLL0 for some line rates, also not updating design

Jump to solution

I have a KCU105 eval board and am running tests on GTH channels. In Vivado 2015.2 I use the Ultrascale FPGAs Transceivers Wizard and am experiencing two issues:

 

[1] I noticed that for some line rates it will not let me select QPLL0 as the PLL type. For example at a line rate of 10Gbps I can select QPLL0 but if I change the rate to 9.6Gbs then QPLL0 is not shown in the pulldown menu. Is this expected? I am using the same settings for Tx and Rx and both sides behave this way.

 

[2] For the first several line rates I had no problem making changes. When I made a change it would automatically open a window for generating output products. Now when I make a change it does not open the window for generating output products and does not re-sythesize the IP. If I re-customize the IP it opens with the old settings (does not have the latest changes). Seems like something in tool has become stuck. This might also explain issue #1.

 

I am going to make a copy of the design and try deleting and recreating the GTH IP.

 

Thanks,

Jason

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar
Scholar
13,363 Views
Registered: ‎06-05-2013

Re: Ultrascale Transceivers wizard not allowing QPLL0 for some line rates, also not updating design

Jump to solution

@jt94093 Correct! there is VCO limitation.

 

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
3 Replies
Highlighted
Adventurer
Adventurer
7,077 Views
Registered: ‎07-26-2013

Re: Ultrascale Transceivers wizard not allowing QPLL0 for some line rates, also not updating design

Jump to solution

I found Table 2-12 in UG576 that clarifies the QPLL0 vs QPLL1 issue. I assume that is what limits me to QPLL1 for some frequencies.

 

So I just have the issue where the wizard does not retain changes to the IP.

0 Kudos
Highlighted
Adventurer
Adventurer
7,074 Views
Registered: ‎07-26-2013

Re: Ultrascale Transceivers wizard not allowing QPLL0 for some line rates, also not updating design

Jump to solution
Deleting and recreating the GTH IP seems to have fixed issue #2.
0 Kudos
Highlighted
Scholar
Scholar
13,364 Views
Registered: ‎06-05-2013

Re: Ultrascale Transceivers wizard not allowing QPLL0 for some line rates, also not updating design

Jump to solution

@jt94093 Correct! there is VCO limitation.

 

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos