cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
127 Views
Registered: ‎08-30-2020

Using EMIO for UART

I previously worked on a Nexys4 DDR board. I created a UART module for this board that directly tied the UART_RXD_OUT output to the IO package pin (pin D4). I recently got the Zybo Z7-10 board. The Zybo board has no UART pin directly available to the PL. Is it possible to use this same module on the new board via EMIO. I tried to enable EMIO and tie this same output signal to the UART0_RX. I can successfully validate the block design. I run synthesis and the implementation without any errors. I only get errors when trying to generate a bitstream. 

 

Attached is a screenshot of the errors I am getting. The block diagram I am using is also shown. I created a simple test module that initializes some registers and uses btn[0] to trigger the transmission of this register data.

 

 

The constrains for this project are the following: 

##Clock signal
set_property -dict { PACKAGE_PIN K17 IOSTANDARD LVCMOS33 } [get_ports { EXT_PL_CLK }]; #IO_L12P_T1_MRCC_35 Sch=sysclk
create_clock -add -name sys_clk_pin -period 8.00 -waveform {0 4} [get_ports { EXT_PL_CLK }];

###Buttons
set_property -dict { PACKAGE_PIN K18 IOSTANDARD LVCMOS33 } [get_ports { btn }]; #IO_L12N_T1_MRCC_35 Sch=btn[0] 

Tags (4)
Vivado Errors.PNG
0 Kudos
0 Replies