UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer skor
Observer
595 Views
Registered: ‎12-21-2015

VIVADO 2018.2 IP packaging

I have a fairly large design, implemented in system Verilog mostly. It synthesizes successfully but when I am trying to package it as IP the whole VIVADO crashes . This happens when Iam trying to merge changes in file group wizard or customization parameters wizard. I get a error report , attached here.

Any idea what is to reason for this problem?

 

Regards , Sirpa

0 Kudos
9 Replies
Observer skor
Observer
593 Views
Registered: ‎12-21-2015

Re: VIVADO 2018.2 IP packaging

dding the error log file. Sorry it was missing from the original question

0 Kudos
Moderator
Moderator
574 Views
Registered: ‎03-16-2017

Re: VIVADO 2018.2 IP packaging

Hi @skor,

 

Make sure you are using supported OS for Vivado 2018.2:

 

oss.JPG

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Observer skor
Observer
534 Views
Registered: ‎12-21-2015

Re: VIVADO 2018.2 IP packaging

hi!

 

my OS is Linux , precisely centos-release-7-6.1810.2.el7.centos.x86_64

 

Regards, skor

0 Kudos
Observer skor
Observer
513 Views
Registered: ‎12-21-2015

Re: VIVADO 2018.2 IP packaging

Hi hemangd,

 

like mentioned in my previous comment my OS is Centos 7.6.  

looking at the list you gave only 7.2, 7.3 and 7.4 are supported. Usually version are backwards compatible but does this still mean that I have wrong OS version?

 

regards, skor

0 Kudos
Moderator
Moderator
503 Views
Registered: ‎03-16-2017

Re: VIVADO 2018.2 IP packaging

Hi @skor,

1. Check your design with supported CentOS version if it is installed in your colleague's machine. Else you may need to use supported CentOS on your machine. 

2. What's the top level of your design? Is it a system verilog file?

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Observer skor
Observer
492 Views
Registered: ‎12-21-2015

Re: VIVADO 2018.2 IP packaging

Hi hemangd ,

1.I'll check my possibilities to try one of the supported OS versions, It is not very straightforward because we decided to use this Centos 7.6 and it is now installed to all of us.

2. Would Vivado 2018.3 make any difference?

3. It is system verilog design, toplevel and most of the other levels also.

 

regards, skor

 

0 Kudos
Moderator
Moderator
481 Views
Registered: ‎03-16-2017

Re: VIVADO 2018.2 IP packaging

Hi @skor,

Make sure the wrapper file is verilog only and not system verilog. 

And Vivado 2018.3 supports till CentOS 7.5.

 

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Highlighted
Observer skor
Observer
450 Views
Registered: ‎12-21-2015

Re: VIVADO 2018.2 IP packaging

Hi hemangd,

I manged to move to Centos 7.4. Vivado 2018.3 I have not yet tried.

 

But when opening the design in Centos 7.4 environment I got message "invalid top module..."  please see the file attached. which of the three options I should choose?

 

Regards, skor

Capture.PNG
0 Kudos
Moderator
Moderator
407 Views
Registered: ‎03-16-2017

Re: VIVADO 2018.2 IP packaging

Hi @skor,

 

1. Specify a new top module by navigating its path. 

2. And also check what critical warnings are shown in the sources window.Resolve it, Because this could be the reason that vivado is not taking top module automatically. (As i can see 2 critical warnings in your last snapshot.)

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos