UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
505 Views
Registered: ‎09-27-2013

Vivado 2017.4 all files deleted in IP module

I'm not sure what exactly happened, but I had an IP directory structure in an IP repo. Everything was going fine: I instantiated the IP in a block diagram, generated a bitstream. No issues with the IP.

 

Out of nowhere, I get the info bar saying one of my IP was out of date. I click the link "Report IP Status", and it says the IP files no longer exist. I use Windows explorer, navigate to the IP directory, and every single file is missing in every single directory. The directory structure is still intact, but there is not a single file left.

 

I'm fairly confident that this was Vivado's doing. The project was located in a local directory, and I had no other programs running.

 

Very bizarre behavior. Luckily I had just checked in a copy of the code into our version control tool.

0 Kudos
2 Replies
Explorer
Explorer
491 Views
Registered: ‎07-03-2014

Re: Vivado 2017.4 all files deleted in IP module

Unfortunately, I had once the same problem than you. I can't explain what happened, maybe is one out of the thousand Vivado bug.

I don't know if it is the solution, even if it is good to you, but that never happened to me again when I changed the repository folder above project folder.

I mean, if my project is located in:

 

C:\Projects\Communication_Core\

 

Then I place my repository folder at the same level:

 

C:\Projects\Library\

 

Hope this helps.

0 Kudos
Moderator
Moderator
430 Views
Registered: ‎06-14-2010

Re: Vivado 2017.4 all files deleted in IP module

Hello @rdb9879,

 

This topic is still open and is waiting for you.

 

If your question is answered and/or your issue is solved, please mark a response that resolved your issue, as Accepted Solution (more info on this can be found here: https://forums.xilinx.com/t5/help/faqpage/faq-category-id/solutions#solutions). This way, the topic can be completed then. 

 

If this is not solved/answered, please reply in the thread.

 

Thanks in advance and have a great day.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos