UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
1,275 Views
Registered: ‎05-25-2016

Vivado ip packager failing to add new port

Jump to solution

Hello,

 

I have a fully functioning custom IP block for a uBlaze design.  I am trying to add an additional input port and the vivado ip packager fails to recognize that I've added it.  Vivado ip packager does recognize the code changed and my "File Groups" icon changes telling me I need to "Merge changes" again.  I've seen from searching the forums that some people have had this issue a few years ago and it was supposed to be fixed.  

 

If I add a new input to the top level axi wrapper (this is an axi memory mapped peripheral by the way) the "Ports and Interfaces" section never recognizes it.  

 

Below is a screenshot of my ip packager:

IP_Packager.jpg

 

AFE_v1_0.v is my top level module of the axi memory mapped peripheral as shown below:  

CustomIP_InputSignalFail.jpg

 

When I comment in and out the STALL_AUTO_COMMS input signal the ip packager shown above never picks it up.

 

Is there a way to force vivado ip packager to refresh and pull in the new ports?

 

 

 

 

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
1,264 Views
Registered: ‎09-15-2016

Re: Vivado ip packager failing to add new port

Jump to solution

Hi @m3atwad,

 

I think this warning is because of AXI Interface Port not being associated with any clock port.

Check this Answer Record AR#64556.

 

Prathik

-----------------------------------------------------------------------------------

Don't forget to reply, kudo, and mark the appropriate post as 'accept as solution'.

-----------------------------------------------------------------------------------

0 Kudos
5 Replies
Xilinx Employee
Xilinx Employee
1,250 Views
Registered: ‎02-01-2008

Re: Vivado ip packager failing to add new port

Jump to solution

In ports and interfaces, right click on the list of ports and select 'import IP ports' and in the popup, make sure the correct file is selected as the top.

 

You will have to rerun 'auto infer interface' to regroup the ports into interfaces.

0 Kudos
Explorer
Explorer
1,219 Views
Registered: ‎05-25-2016

Re: Vivado ip packager failing to add new port

Jump to solution

Ok.  I've managed to get there for the most part, but because of this process I now have two new warnings shown below.  Do you understand what these mean?  They were not there when I created the peripheral from scratch.  It sounds like Vivado wants me to define the axi bus frequency for one warning.  The other I totally don't understand and there were no answer records.

 

In case it is hard to read on the image here are the warnings. 

 

Warning1: [IP_Flow 19-3158] Bus Interface 'S00_AXI': FREQ_HZ bus parameter missing from AXI interface when interface is not associated to a clock.

Warning2: [IP_Flow 19-3153] Bus Interface 's00_axi_aclk': ASSOCIATED_BUSIF bus parameter is missing.

 

 

 

IP_Pack_warning.jpg

 

 

IP_Pack_warning.jpg
0 Kudos
Moderator
Moderator
1,265 Views
Registered: ‎09-15-2016

Re: Vivado ip packager failing to add new port

Jump to solution

Hi @m3atwad,

 

I think this warning is because of AXI Interface Port not being associated with any clock port.

Check this Answer Record AR#64556.

 

Prathik

-----------------------------------------------------------------------------------

Don't forget to reply, kudo, and mark the appropriate post as 'accept as solution'.

-----------------------------------------------------------------------------------

0 Kudos
Explorer
Explorer
1,149 Views
Registered: ‎05-25-2016

Re: Vivado ip packager failing to add new port

Jump to solution
That is correct. That was my problem, I didn't realize you had to associate them.
0 Kudos
Moderator
Moderator
1,130 Views
Registered: ‎09-15-2016

Re: Vivado ip packager failing to add new port

Jump to solution

Thanks for the update!

 

Regards

prathikm

0 Kudos