UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer silvaurus
Observer
194 Views
Registered: ‎10-21-2016

Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

Hi!

Could you help me figure out what causes this error?

Software Used: Vivado 2018.3

Design flow:  (1) Create a project A, which is a fairly large project with a AXI master output. Pack A to be IP_A. (2) Create an AXI peripheral wrapper IP_B, inside of this project using IP_A (I want to have a general AXI peripheral interface so I wrap A with a AXI wrapper) I've also tried just defining the entire project A directly in this AXI peripheral interface, and the problem remains. (3) Create a block design, connecting Zynq SoC with IP_B, generating output products.

Error: module 'IP_A' not found.

Error description: It seems like IP_A can not be found even it is used in IP_B.

I have tried: (1) In generating IP_A, copy all the source files to the IP. (2) Adding a separate IP_A instance to the project that I used for block design. (3) Adding the path of IP_A to the IP repository searching path. The problem still remains.

 

Thanks a lot!

 

0 Kudos
1 Solution

Accepted Solutions
Observer silvaurus
Observer
136 Views
Registered: ‎10-21-2016

Re: Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

Sorry, problem resolved.

 

When I created the AXI peripheral IP, I added user logics to the top module (IP_NAME_v1_0.v). They should have gone to one layer below, to the IP_NAME_v1_0_X_AXI.v file.

0 Kudos
4 Replies
Observer silvaurus
Observer
192 Views
Registered: ‎10-21-2016

Re: Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

The reason why I defined an AXI peripheral wrapper IP_B for A is also that in Tools-> Create and Package new ip -> Create a new AXI4 peripheral it can only add files but not directories. Since the design A includes multiple directories I just wrap it as IP_A first.

I did try using tcl command to add all the source files to the AXI peripheral project directly, so as to getting rid of IP_A, and when I add this peripheral IP to block design, the result seems to be the same: The submodules inside of this AXI peripheral is not found.

I guess to better describe this question, it might be something that I did wrong in building an AXI peripheral IP...

0 Kudos
Observer silvaurus
Observer
178 Views
Registered: ‎10-21-2016

Re: Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

Found in Setting->IP->Packager the Default Library is set to be 'user', while in the block design, the ip shown in Sources (with a red question mark indicating not found) actually looks like 'xil_defaultlib.xxxx'. Could that be the cause?

0 Kudos
Observer silvaurus
Observer
143 Views
Registered: ‎10-21-2016

Re: Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

Sorry for the confusion. I tried some more things today and found it's just that if I wrap a user-defined IP outside another user-defined IP, then the inner one will be reported as 'not found' in application. I'm wondering if there are something wrong that I did during packaging could lead to this.

Thanks a lot!

 

 

0 Kudos
Observer silvaurus
Observer
137 Views
Registered: ‎10-21-2016

Re: Vivado 'module not found' Error for a user-defined IP inside of another IP

Jump to solution

Sorry, problem resolved.

 

When I created the AXI peripheral IP, I added user logics to the top module (IP_NAME_v1_0.v). They should have gone to one layer below, to the IP_NAME_v1_0_X_AXI.v file.

0 Kudos