UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor cbozarth
Visitor
5,567 Views
Registered: ‎02-18-2009

XUP Virtex-II Pro - ISE Issue

Hi all,

 

I'm trying to get "built_in_demo_rev_1_1" to work on my board. It can be found here:

 

http://www.digilentinc.com/Data/Products/XUPV2P/Built_in_Demo_rev_1_1.zip

 

Unfortunately, I'm getting some errors.  The errors that I'm getting are related to the MPD and the MDT files.  I'm new to FPGA programming and am kind of lost as to where to go from here.  Here is an example of one of the errors I am getting when I am trying to build the XMP file in ISE.

 

ERROR:MDT - INST:opb_bram_if_cntlr_1_bram PORT:BRAM_WEN_B CONNECTOR:bram_wen -
ERROR:MDT - platgen failed with errors!
ERROR:MDT - Error while running "make -f system.make netlist"

 

The other error concerns that the MPD file is not found when I build the project with EDK. I have looked around, but have not even been able to figure out what these files are for.

 

I am so lost and would appreciate any help anyone can extend.

 

Thanks,

Colin

0 Kudos
2 Replies
Explorer
Explorer
5,499 Views
Registered: ‎01-04-2009

Re: XUP Virtex-II Pro - ISE Issue

Hi,

do a search for  my name or the XUPV2P board and you will find out eveything I found out to get the thing working.

I too was new , going from absolutly knowing nothing, to knowing slightly less than nothing ;-)

 

MANY of the OLD projects WILL NOT BUILD , and the  XUPV2P WILL NOT WORK with more than 256mb of ram, there were changes made to the memory module IP.

 

1.first thing you need to do is get a 256mb ram board , (yep don't bother telling me how everyone says the 512mb works, it dont!!) , If you cannot get a 256mb then it just means you  need to  generate ram INSIDE the FPGA, which is really limited in size, but it is certainly big enough to get various projects working.

 

 

 

2. ENSURE you have  ISE OR  XilinxPlatform studio. (personally I would start with the  XPS) (do not bother with the other **bleep**, modlesim,DSPtools,planahead,chipscope,etc until you understand and can use XPS)

 

3. ENSURE they are updated to 10.1.3, if they are not they will not work correctly with the  XUPV2P. 

 

4. download and install the NEW XUPV2P files (lib_xupv2p_edk_10_1_sp3.zip) , it will make your job a bit easier.

 

 

I'm not saying i'm an expert or this is the correct way to do it ,  BUT I can get you running to a level where you can  be building stuff.

You will have to be focused though....

 

Steve

 

 

 

 

Visitor cbozarth
Visitor
5,303 Views
Registered: ‎02-18-2009

Re: XUP Virtex-II Pro - ISE Issue

Hi,

 

Thanks for your reply.  I just ordered a 256MB of DDR SDRAM 266. 

 

As far as the software, I do have 10.1.03 but didn't have the new XUPV2P files.  Thanks for that help, however it seemed as though some of the files from the original lib were missing.  I'm going to add them with the new files, because I couldn't find the AC97 codec when I went through Base System Builder again.

 

 Appreciate your help, I'll try to figure out how to get the XPS to do what I'd like it to do.

 

-Colin

0 Kudos