cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nibal
Explorer
Explorer
9,008 Views
Registered: ‎02-10-2016

blk_mem_gen_8.3 bd.tcl bug in Vivado 2015.4

Hi,

 

Although said component sports AXIS interfaces, they are not supported in its bd.tcl, with the result of this error:

 

ERROR: [BD 41-1273] Error running post_config_ip TCL procedure: ERROR: [Common 17-55] 'set_property' expects at least one object.
::xilinx.com_ip_blk_mem_gen_8.3::post_config_ip Line 14

 

and open_bd_design failing due to it, unless PORTA & PORTB are defined.

 

Plz fix, and do smt about these error messages. They are confusing and missleading.

 

 

 

 

0 Kudos
3 Replies
vemulad
Xilinx Employee
Xilinx Employee
8,965 Views
Registered: ‎09-20-2012

Hi @nibal

 

Are you manually creating the bd tcl? Can you attach the TCL file here?

Thanks,
Deepika.
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (the star on the left)
nibal
Explorer
Explorer
8,962 Views
Registered: ‎02-10-2016

Hi @Deepika,

 

Ty for your fast reply. 

No. This is Xilinx software, and I am referring to the stock bd.tcl for blk_mem_gen_8.3 from vivado 2015.4 (/opt/Xilinx/Vivado/2015.4/data/ip/xilinx/blk_mem_gen_v8_3/bd/bd.tcl).

I would be very curious if your stock bd.tcl differs from mine. Regardless, I'm attaching it, and plz let me know if you see any differences...

pd.kermani
Contributor
Contributor
2,964 Views
Registered: ‎09-08-2015

Hi,

 

I've got the same error while re-customizing Aurora64b66b at 8.0gbps in Vivado 2016.2 on Kintex-Ultrascale with following error:

 

set_property -dict [list CONFIG.C_LINE_RATE {8.0} CONFIG.C_REFCLK_FREQUENCY {800}] [get_bd_cells aurora_64b66b_0]
ERROR: [Common 17-55] 'set_property' expects at least one object.
Resolution: If [get_<value>] was used to populate the object, check to make sure this command returns at least one valid object.
ERROR: [BD 41-1273] Error running post_config_ip TCL procedure: ERROR: [Common 17-55] 'set_property' expects at least one object.
    ::xilinx.com_ip_aurora_64b66b_11.1::post_config_ip Line 806
INFO: [Common 17-17] undo 'set_property -dict [list CONFIG.C_LINE_RATE {8.0} CONFIG.C_REFCLK_FREQUENCY {800}] [get_bd_cells aurora_64b66b_0]'
ERROR: [Common 17-39] 'set_property' failed due to earlier errors.
endgroup

 

Moreover, there is no problem if I set other Lane rate like 4.0, 6.0 or 12.5.

0 Kudos