cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
11,430 Views
Registered: ‎02-05-2015

clocking wizzard throws error while instantiating in IPI

Dear community,

 

I am using the ZedBoard without the PS side. My Goal is to create a 50MHz clock for my logic. So I use the 100MHz PL clock (the ZedBoard provides a 100MHz clock at Zynq pin Y9).

To get the 50MHz I am trying to use a MMCM which I would like to create with the clocking wizard. Therefore I do the following steps in Vivado 14.4:

  1. creating new rtl project without any design files and choosing the zedboard
  2. create block design
  3. add ip --> clocking wizard

Then the following error occurs without instantiating the clock wizard (list of tcl commands):

 

create_project clocking_wizard_test C:/Users/abcd/VHDL_Code/Vivado_Testground/clocking_wizard_test -part xc7z020clg484-1
INFO: [IP_Flow 19-234] Refreshing IP repositories
INFO: [IP_Flow 19-1704] No user IP repositories specified
INFO: [IP_Flow 19-2313] Loaded Vivado IP repository 'C:/Xilinx/Vivado/2014.4/data/ip'.
set_property board_part em.avnet.com:zed:part0:1.2 [current_project]
set_property target_language VHDL [current_project]
create_bd_design "design_1"
Wrote  : <C:/Users/abcd/VHDL_Code/Vivado_Testground/clocking_wizard_test/clocking_wizard_test.srcs/sources_1/bd/design_1/design_1.bd>
startgroup
create_bd_cell -type ip -vlnv xilinx.com:ip:clk_wiz:5.1 clk_wiz_0
ERROR: [#UNDEF] conversion to double from string is failed
unexpected "," outside function argument list
in expression "1000 / 10,000"
ERROR: [IP_Flow 19-3188] Error occurred while initializing 'clk_wiz_0'
Tcl error in update procedure while setting value 'MMCM' on the parameter 'PRIMITIVE'. unexpected "," outside function argument list
in expression "1000 / 10,000"

CRITICAL WARNING: [IP_Flow 19-973] Failed to create IP instance 'design_1_clk_wiz_0_0'. Error during customization.
ERROR: [#UNDEF] Error occurred while initializing 'clk_wiz_0'
Tcl error in update procedure while setting value 'MMCM' on the parameter 'PRIMITIVE'. unexpected "," outside function argument list
in expression "1000 / 10,000"

ERROR: [BD 5-7] Error: running create_bd_cell.
ERROR: [Common 17-39] 'create_bd_cell' failed due to earlier errors.
endgroup

 

 

How can I fix it?

0 Kudos
Reply
7 Replies
Highlighted
Scholar
Scholar
11,426 Views
Registered: ‎06-05-2013

Hi @irshs,

check this thread

http://forums.xilinx.com/t5/Design-Entry/Connection-Automation-failed-with-a-simple-MicroBlaze-design/td-p/539137

 

Can you try to use IP in native mode?

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Reply
Highlighted
Visitor
Visitor
11,420 Views
Registered: ‎02-05-2015

you mean setting the system langage to US English?

0 Kudos
Reply
Scholar
Scholar
11,416 Views
Registered: ‎06-05-2013

give a try, which language did you set currently?
-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Reply
Highlighted
Visitor
Visitor
11,408 Views
Registered: ‎02-05-2015

Its currenty set to German.

 

What they described in the answer record AR#51331 is that they somehow managed it to set the language locally just for Vivado. But it seems that they used Linux and they modified their startup script. How can I start Vivado with those parameters with win7?

 

I can try to work arround this issue with setting the system language global to english. But this won´t be a good solution for me to change it everytime I want to start Vivado. Anyway I try it and give you feedback.

0 Kudos
Reply
Highlighted
Scholar
Scholar
11,404 Views
Registered: ‎06-05-2013

hi @irshs,

 

Check this, might help you

 

http://superuser.com/questions/384775/can-i-start-particular-program-with-different-language-settings-in-windows

 

 

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Reply
Highlighted
Visitor
Visitor
11,383 Views
Registered: ‎02-05-2015

Thanks first of all for your replies.

 

Allright, now I got some results. Or in different words: I can reproduce a strange behavior regarding the clocking wizard:

  1. Leave the system language (win7) set to German and changing just the decimal separator (,) with (.) it does not work.
  2. When I got the error message (see initial thread) than I can work around with closing Vivado and reopen it. If I try to instantiate the MMCM with the clocking wizard after reloading Vivado then it works (without error or warning messages). I even can gernerate a bitstream. But everytime I open a synthesized or implemented design I get the above mentioned errors. If I delete the clocking wizard at the IPI and try to add a "new" one then Vivado refuses it again (at least until I close Vivado and reopen it again). With this method I would say it works almost ;-)
  3. set the system language (win7) globally to US English it works. At least I wasn´t able to reproduce this error.

Is this issue planned to be fixed in the next version of Vivado?

 

Regards!

0 Kudos
Reply
Highlighted
Observer
Observer
10,470 Views
Registered: ‎04-27-2009

I can reproduce this issue in Windows 8, Vivado 2014.4 with a specific setting:

 

System language English, date time and number format setting German, the decimal symbol set to . and the digit group to , (like in English) does not work.

 

Resetting the format customization to German works.

 

0 Kudos
Reply