cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
760 Views
Registered: ‎12-27-2019

[filemgmt 20-2001] Source scanning failed (launch error) while processing fileset ...

Windows 7 x64 Home Basic SP1 Russian Edition

Antivirus is not installed.

Vitis 2019.2

****** Vivado v2019.2 (64-bit)
**** SW Build 2708876 on Wed Nov 6 21:40:23 MST 2019
**** IP Build 2700528 on Thu Nov 7 00:09:20 MST 2019

When opening old projects or creating new projects (for example  - "UG888 (v2019.2) Vivado Design Suite Tutorial Lab 2: Using the Project Design Flow" - from folder ..\Xilinx\Vivado\2019.2\examples\Vivado_Tutorial ), the projects's sources files are placed in the "Non-module Files" section"
and I get critical warnings:

[filemgmt 20-2001] Source scanning failed (launch error) while processing fileset "sim_1" due to unrecoverable syntax error or design hierarchy issues. Recovering last known analysis of the source files.
[filemgmt 20-2001] Source scanning failed (launch error) while processing fileset "sources_1" due to unrecoverable syntax error or design hierarchy issues. Recovering last known analysis of the source files.

Shortening system environment variable %PATH% - does not help.
Utility from Answer Record 71064 (boostSharedDirFixApp.zip) - does not help.
The advice "Execute windows command shell (cmd.exe) with “Run as Administrator” then change the directory to Vivado installation path and execute settings64.bat. Then invoke vivado using “vivado” command. This will invoke vivado GUI then open/create a project and check" - does not help.
Complete reinstallation - does not help.

 


What the problem could be?

0 Kudos
7 Replies
Highlighted
Xilinx Employee
Xilinx Employee
750 Views
Registered: ‎04-16-2012

Hi @sergu 

Check if this answer record helps: https://www.xilinx.com/support/answers/52787.html 

Thanks,
Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Observer
Observer
739 Views
Registered: ‎12-27-2019

The longest path to the file I had
D:\Vivado_Tutorial\Tutorial_Created_Data\project_bft\project_bft.srcs\sources_1\imports\hdl\bftLib\core_transform.vhdl - 118 chars

Tried the shortened folder names
D:\X\p1\p1.srcs\sources_1\imports\hdl\bftLib\core_transform.vhdl - 64 chars

Warnings are still issued.

0 Kudos
Highlighted
Moderator
Moderator
734 Views
Registered: ‎01-16-2013

@sergu 

 

This could be because of unsupported OS. If possible can you try in any other machine?

Windows 7 x64 Home Basic SP1 Russian Edition

 

Here is the list of supported OS: 

https://www.xilinx.com/support/documentation/sw_manuals/xilinx2019_2/ug973-vivado-release-notes-install-license.pdf#page=8 

image.png

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
662 Views
Registered: ‎12-27-2019

I can probably try it somewhere, but I still wanted to use Vivado on a specific machine, which is still impossible to change the OS.

And what problems can there be because of the OS language ?

All project folders and Vivado folders do not contain non-english characters . The user name on the PC is in english, and the PC name is also in english. What then prevents Vivado from working properly?

0 Kudos
Highlighted
Moderator
Moderator
642 Views
Registered: ‎01-16-2013

@sergu 

 

I have seen corner cases where the files (xml , prj) generated by vivado were having incorrect characters that were narrowed down to due unsupported language settings in OS.  As you are using Xilinx tutorial file which are tested, the unsupported OS could be the reason for this issue. 

 

Can you update us back after trying on a different machine? 

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
616 Views
Registered: ‎12-27-2019

It is unlikely that this is due to filenames . When trying to add a new file to a project and immediately after issuing a warning, Vivado  accesses only 4 files (filenames - "good"):

1.gif


If I will be able to check the Vivado 2019.2 in eng. version of Win7x64 on another PC, then of course I will write here about the results.

0 Kudos
Highlighted
Contributor
Contributor
189 Views
Registered: ‎04-08-2009

For what it's worth ...

I stumbled on the same issue on Linux. After numerous attempts I found what I was doing wrong.

I started Vivado through the Command Line, in the folder in which I wanted to make the project. After a few iterations of deleting and recreating folders, I started getting the same error message.

My solution: close Vivado, navigate a couple of layers up (or down) in your folder tree and start again. There could have been some inconsistencies in the file system where a folder that once existed, got deleted, and recreated.

0 Kudos