UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor rnp
Visitor
321 Views
Registered: ‎06-01-2019

vivado editor vhdl cursor at the end of line issue

Jump to solution

Hello everybody,

I am using the vivado to edit/enter VHDL code and I am having the following issue:

1 - open vhdl file

2 - edit entity port

3 - go to the end of line

4 - cursor stays 2 characters before the end of the line

This is quite incovenient behaviour, makes it difficult to edit/enter new VHDL code. Any suggestions? Thanks in advance.

 

Additional Information:

- Vivado 2018.3 / 2019.1

- Arch Linux /  5.2.1-arch1-1-ARCH

 

 

vivado_vhdl_editot_error.png
0 Kudos
1 Solution

Accepted Solutions
Visitor rnp
Visitor
178 Views
Registered: ‎06-01-2019

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

Hello @hemangd ,

Sorry for the late reply and Thanks for pointing out the UG973. I installed Ubuntu 18.04.3 LTS (64-bit) + Vivado 2019.1  Update 2, and the error did not occur.

Nevertheless, I found a work around  for the cursos positioning error, it may be helpful for someone else using a Linux distribution that is not supported:

1 - In the flow navigator, click on Settings, direcltly under PROJECT MANAGER)

2-  Under Tool Settings,  click on Text editor, and in the sub-option VDHL

3- Unter Text Styles listbox, click on IEEE

4- On the right side uncheck the bold checkbox (see attached image file)

5- Click on OK to apply the change and close the Settings window

 

Regards,

rnp

vivado_vhdl_editor_error_workaround.png
6 Replies
Scholar dpaul24
Scholar
294 Views
Registered: ‎08-07-2014

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

@rnp,

This is quite incovenient behaviour, makes it difficult to edit/enter new VHDL code. Any suggestions? Thanks in advance.

Do not use the Vivado supplied editor. It is crap and there are remote chances of it being improved.

Most of us here here don't use the built-in editor. If you are on Windows platform, suggestion is to switch to Notepad++. If you are on Linux, use your favourite editor (Nedit, emacs, etc).

Vivado can be configured from its Tools --> Settings to use the editor of your choice.

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
0 Kudos
Visitor rnp
Visitor
252 Views
Registered: ‎06-01-2019

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

I agree, the editor has a lot of problems, but I could not imagine that a problem with such a simple functionality could happen.

It is also quite unfortunate that Xilinx does not put an effort to fix such simple (but annoying) bugs .

Cheers.

0 Kudos
Scholar dpaul24
Scholar
246 Views
Registered: ‎08-07-2014

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

@rnp,

It is also quite unfortunate that Xilinx does not put an effort to fix such simple (but annoying) bugs .

It is because the in-built text editor is a non-revenue generating entity for Xilinx. :-)

--------------------------------------------------------------------------------------------------------
FPGA enthusiast!
All PMs will be ignored
--------------------------------------------------------------------------------------------------------
0 Kudos
Scholar drjohnsmith
Scholar
241 Views
Registered: ‎07-09-2009

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

Dont hold your breath

Its evident that Xilinx do not use VHDL internally, so its very unlikely to get fixed.

Suggestion is to install the notepad++ external editor, that can be substituted in vivado directly ,

https://www.xilinx.com/support/answers/57719.html

https://notepad-plus-plus.org/download/v7.7.1.html

Feel free to Kudos if ths was helpfull

 

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Moderator
Moderator
222 Views
Registered: ‎03-16-2017

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

Hi @rnp,

The issue is not reproducible at my end. 

I will suggest use supported OS for Vivado 2019.1 and then check. 

From UG 973: 

Supported Operating Systems
Xilinx® supports the following operating systems on x86 and x86-64 processor architectures.
• Microsoft Windows 7 SP1 Professional (64-bit), English/Japanese
• Microsoft Windows 10.0 1809 Update; 10.0 1903 Pre-release (64-bit), English/Japanese
• Red Hat Enterprise Workstation/Server 7.4, 7.5, and 7.6 (64-bit)
• SUSE Linux Enterprise 12.4 (64-bit)
• CentOS 7.4, 7.5, and 7.6 (64-bit)
• Ubuntu Linux 16.04.5, 18.04.1 LTS (64-bit)

 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
Visitor rnp
Visitor
179 Views
Registered: ‎06-01-2019

Re: vivado editor vhdl cursor at the end of line issue

Jump to solution

Hello @hemangd ,

Sorry for the late reply and Thanks for pointing out the UG973. I installed Ubuntu 18.04.3 LTS (64-bit) + Vivado 2019.1  Update 2, and the error did not occur.

Nevertheless, I found a work around  for the cursos positioning error, it may be helpful for someone else using a Linux distribution that is not supported:

1 - In the flow navigator, click on Settings, direcltly under PROJECT MANAGER)

2-  Under Tool Settings,  click on Text editor, and in the sub-option VDHL

3- Unter Text Styles listbox, click on IEEE

4- On the right side uncheck the bold checkbox (see attached image file)

5- Click on OK to apply the change and close the Settings window

 

Regards,

rnp

vivado_vhdl_editor_error_workaround.png