UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor knugent
Visitor
101 Views
Registered: ‎05-31-2019

xbip_multadd_0 was not recognized as a sub module of my top_level shuffler_1 .vhd code !

Hi,

I generated a Multiply Adder xbip_multadd_0 IP via ip catalog to my current project. Within one of my user modules (eg shuffler_1.vhd rtl code) I then declared the component xbip_multadd_0 + instantiation (mult_add_inst:xbip_multadd_0). My shuffler_1.vhd code had no syntax errors. I then expected to see on the sources window the xbip_multadd_0 to be recognized as a sub module of the shuffler_1. However, this was listed as

mult_add_inst:xil_defaultlib.xbip_multadd_0    with a ? (ie file not found!). 

I tried adding to my shuffler_1 the following at the very top :

library xil_defaultlib;

use xil_defaultlib.all;

 

but still I could not get the xbib_multadd_0 to be recognized as a submodule of my shuffler_1 code. Any suggestions to what I am doing wrong here?

Also, why it has added xil_default library name ? Noticed that this was the default library in the project manager settings window. 

On other cases when I instantiated a Dual Port RAM (from the IP catalog) in other top-level .vhd codes, this was always recognized ok without adding the xil_default library name.

Will appreciate a prompt reply to this matter & how to resolve it.

Regards,

Kevin

0 Kudos
1 Reply
Visitor knugent
Visitor
68 Views
Registered: ‎05-31-2019

Re: xbip_multadd_0 was not recognized as a sub module of my top_level shuffler_1 .vhd code !

Hi All,

Silly me ! The name I used in the VHDL was xbib_multadd_0 and not xbip_multadd_0. 

Problem is now resolved :-)

 

 

0 Kudos