UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
7,205 Views
Registered: ‎06-17-2015

Autoscale in waveform view does not scale down

Since, again, this follow-up question in another thread has not been answered, I will post it as a new thread here.

 

The autoscaling in the waveform viewer does not seem to be working as one expects.

When I switch to analog view the first time, it scales fine to the actual range of the signal.

Once the signal exceeds the scale, it will rescale. But if the signal is within a smaller interval again after retriggering, it will not scale back.

Hence, the autoscale seems to work only in one direction.

I tried

1) switching back to digital and then analog again - no rescaling

2) Analog setting, toggle between auto and fixed - no rescaling

3) trigger the signal again - no rescaling

The only thing that helps is to restart the software, or to remove and add the probes again (which is very annoying, if one considers my other question here...   Probes in Waveform View added twice

 

How can this be solved?

 

Best regards

Johannes

0 Kudos
1 Reply
95 Views
Registered: ‎09-05-2018

Re: Autoscale in waveform view does not scale down

I found this post in searching for a solution to this exact problem.  The original post is almost 4 years old.  I guess this issue still has not been fixed in Vivado's waveform viewer?!  I am using 2018.2.

I tried manually setting the analog Y-range to see if that would help.  It did not.  Furthermore, the windows where the max/min values are entered are very narrow and don't show what values you enter.

Is there a plan to fix these scaling issues with the analog waveform viewer?  The analog display mode is very useful, but much less so with this deficiency in the scaling.

0 Kudos