UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor dbekker
Visitor
5,704 Views
Registered: ‎03-24-2008

Can't get smartxplorer to run on multiple linux machines

Jump to solution

Hello,

 

Does anyone have smartxplorer working on multiple networked linux machines?

 

I have two machines for now, comp_A and comp_B. I am starting smartxplorer on comp_A with the hope of having it start jobs on both comp_A and comp_B. I have setup passwordless ssh from comp_A to comp_B, and also from comp_A to comp_A (to self). I have two machines in my hosfile.txt - comp_A and comp_B.

 

When I run smartxplorer, I see map get started on comp_A, but nothing is started on comp_B (remote machine). There is ssh traffic between the two machines (I checked with wireshark).

 

Both of these machines have Xilinx 11.3 installed locally in the same directories. All of the environment variables between the two machines are the same, set in /home/username/.profile.

 

Can someone see what's wrong here?

 

Thanks!

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
6,744 Views
Registered: ‎11-28-2007

Re: Can't get smartxplorer to run on multiple linux machines

Jump to solution

The project directory needs to be accessible by all hosts on your list.

 

Cheers,

Jim

 

Cheers,
Jim
0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
5,688 Views
Registered: ‎11-28-2007

Re: Can't get smartxplorer to run on multiple linux machines

Jump to solution

Is the project directory on a network drive that is mounted on both comp_A and comp_B?

 

When you directly ssh from A to B, what happends?

 

Can you post your smartxplorer command line?

 

 

Cheers,

Jim

 

Cheers,
Jim
0 Kudos
Highlighted
Visitor dbekker
Visitor
5,682 Views
Registered: ‎03-24-2008

Re: Can't get smartxplorer to run on multiple linux machines

Jump to solution

Hi Jim,

 

Thanks for your help.

 

The ISE project directory is not on a network drive. It is only on comp_A. I was under the impression that smartxplorer copies the necessary file over to comp_B when it run.

 

When I ssh directly from comp_A to comp_B, I get a company mandated "WARNING" greeting, an OS greeting, warranty disclaimer, package status, mail info, last login, and finally the prompt.

 

Here is the command that I run on comp_A (this I tried running both from ISE and terminal with same results):

user@comp_A:~/<project_dir>$ smartxplorer -p xc5vfx70t-ff1136-1 -b -wd smartxplorer_results system.ngd -host_list hostlistfile.txt -rcmd ssh -max_runs 7

 

Thanks

 

Dmitriy

0 Kudos
Xilinx Employee
Xilinx Employee
6,745 Views
Registered: ‎11-28-2007

Re: Can't get smartxplorer to run on multiple linux machines

Jump to solution

The project directory needs to be accessible by all hosts on your list.

 

Cheers,

Jim

 

Cheers,
Jim
0 Kudos
Visitor dbekker
Visitor
5,513 Views
Registered: ‎03-24-2008

Re: Can't get smartxplorer to run on multiple linux machines

Jump to solution

Thanks Jim. This was my problem. Once my project was on the network, everything worked fine.

 

Dmitriy

0 Kudos