UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie myarger
Newbie
2,975 Views
Registered: ‎04-16-2009

ISE Text Editor Default End of Line Behavior

Hello,

 

Does anyone know how to configure the default end of line behavior in the ISE Text Editor (v. 10.1.03 nt)?  Every time I open a file all line ending are converted to UNIX style LF characters even if they were DOS type CRLF before the file was opened.  If I press the "Enter" key the text editor inserts the CRLF line ending, which is correct as I am on using Windows.  I have found the menu option that lets me convert the file manually each time I open it or just before I save it, but I have been unable to find a place to configure a default behavior.  Normally I wouldn't care too much because I really only use ISE to edit Verilog files.  The problem is that this is causing some issues for our source control software when it does file comparisons.

 

Thanks.

 

Mike

0 Kudos