UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor chungae9ri
Visitor
375 Views
Registered: ‎06-21-2016

Platform Cable USB II DLC10 doesn't work

Jump to solution

Hi Professional,

 

I have been using Platform Cable USB II model DLC9LP successfully with my company's custom board (Zynq7000). I purchased recently a new one model name DLC10 but it doesn't work with my board. Cable connection and everything is same but the Platform Cable USB II model is the difference. When I tried DLC10 model, my vivado 2018.3 complains following error with Amber status LED.

" [Labtoolstcl 44-494] There is no active target available for server at localhost.
Targets(s) ", jsn1jsn-DLC9LP-00000acb5b9001jsn-DLC10-000012929a5301" may be locked by another hw_server."

Can't I use DLC10 model for my zynq7000?

Any help appreciated.

0 Kudos
1 Solution

Accepted Solutions
Scholar u4223374
Scholar
282 Views
Registered: ‎04-26-2015

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

Just to check - this is a Platform Cable USB II bought from Xilinx or an authorized distributor, right? Not a "Platform Cable USB II" bought from eBay? Because the cheap eBay ones are a pretty mixed bag at the best of times.

6 Replies
Moderator
Moderator
325 Views
Registered: ‎02-09-2017

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

Hi @chungae9ri,

 

Did you have the HW Manager already open before trying to plug in the cable?

Can you please try to close all the Vivado instances open, and also check the task manager for any hw_server process open. If there is any, end the process, disconnect any other cable (leave only the DLC10) plugged in, and then open the HW Manager again try to re-connect the board. 

Also, make sure that your USB port is capable to provide enough power (at least 150-200mA). You might want to try to switch to a few different USB port in your host and try it.

Let us know if it still didn't work so we can continue to help you in debugging it.

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor chungae9ri
Visitor
314 Views
Registered: ‎06-21-2016

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

I tried following things but all fail.

1. close my vivado 2018.3 and reconnect.

2. tries other USB ports

3. uninstall vivado 2018.3 and reinstall 2018.3

4. install older version of vivado 2016.2

5. tries other PCs.

I am pretty sure my laptop USB port is good because my coworker's platform cable works fine with my laptop. I also checked the Vref is 3.1V which is good.

I am losing my work hours because of this. Any helps really appreciated.

Visitor kyi
Visitor
310 Views
Registered: ‎12-11-2018

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

I am seeing exactly same issue here. 

I am using vivado 2018.3 and platform cable USB II DLC 10. I also checked the Vref > 1.5V.

I am also stuck in progress because of this.

0 Kudos
Moderator
Moderator
298 Views
Registered: ‎06-05-2013

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

@kyi @chungae9ri

Try to check task manager is there any hardware session(hw_server.exe) open. End the process for all of them and try to re-connect the board.

Could you please confirm which OS you are using?


Please share the cable snapshot which you are using? From the error message it seems you have 2 cables (DLC9LP & DLC10) connected. 

 

jsn1jsn-DLC9LP-00000acb5b9001jsn-DLC10-000012929a5301

Amber LED status is indication of either power issue (VREF OFF)  or driver issues.

Try Installing drivers again would be helpful.

Steps to follow:-

 

  • What happens when you open Vivado Hardware Manager and do "Open target" --> "Auto Connect"? --- Nothing works. Move to step 2.

 

  • Go to device manager> Right click on “Platform USB ” in the device manager and click “Uninstall”.

daaadq.png

                      

  • When the uninstall dialog popped up then checked the box that says “Delete the driver software for this device.” And then click ok.

 

               daada.png

 

  • Once driver uninstall completed please disconnect the programming cable. Launch a command prompt in administrator mode and navigated to "C:\Xilinx\Vivado\2017.x or 2018.x\data\xicom\cable_drivers\nt64\dlc10_win7". Once in this directory please run the following 4 commands:

 

                             wdreg -compat -inf %cd%\windrvr6.inf uninstall

                             wdreg -compat -inf %cd%\xusbdrvr.inf uninstall

                             wdreg -compat -inf %cd%\windrvr6.inf install

                             wdreg -compat -inf %cd%\xusbdrvr.inf install

 

 

  • Now what happens when you open Vivado Hardware Manager and do "Open target" --> "Auto Connect or open new target"?

Thanks

harshit

 
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Scholar u4223374
Scholar
283 Views
Registered: ‎04-26-2015

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

Just to check - this is a Platform Cable USB II bought from Xilinx or an authorized distributor, right? Not a "Platform Cable USB II" bought from eBay? Because the cheap eBay ones are a pretty mixed bag at the best of times.

Visitor chungae9ri
Visitor
217 Views
Registered: ‎06-21-2016

Re: Platform Cable USB II DLC10 doesn't work

Jump to solution

I am so sorry, I bought this from eBay. I will return this. Thank you.

0 Kudos