UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

Vivado 2018.1 ILA Bitstream Generation Extremely Slow

Highlighted
Newbie
Posts: 1
Registered: ‎05-16-2018

Vivado 2018.1 ILA Bitstream Generation Extremely Slow

I am attempting to view signals in a simple design using the Clocking Wizard and SerialIO IPs, but after selecting which nets to debug and clicking "Generate Bitstream", Vivado has been running route_design for well over an hour. Are there any ways to speed up this process?

Visitor
Posts: 10
Registered: ‎12-18-2017

Re: Vivado 2018.1 ILA Bitstream Generation Extremely Slow

Try to reduce its buffer-size (higher values tend to get ridiculously slow!)

Moderator
Posts: 98
Registered: ‎02-09-2017

Re: Vivado 2018.1 ILA Bitstream Generation Extremely Slow

Hi @bklopp,

 

If you generate the bitstream without the ILA does it goes much faster?

 

How many ILAs and how many probes do you have in the design? If you try with one ILA and only one probe (just for testing purposes), does it get faster or still very slow?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Newbie
Posts: 1
Registered: ‎05-17-2018

Re: Vivado 2018.1 ILA Bitstream Generation Extremely Slow

One ila with 9 probes. It generates in about two minutes with no ila.