cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
5,268 Views
Registered: ‎09-03-2013

AXI Quad SPI transfer width problem

Jump to solution

Hi,

 

We are using Vivado 2013.4 and Zynq7030 and AXI Quad SPI IP to make single 32-bit SPI interface.  When testing with our proto we get only 29 clock cycles instead of 32 clock cycles.

 

AXI Quad SPI Vivado configuration is attached below. SPI mode is selected by SW. Mode selected is Mode 0 (CPOL = 0 and CPHA = 0).  Any glue what’s wrong?

 

Best Regards,

Ville-Veikko

 

axi_spi_config2.PNG

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
6,383 Views
Registered: ‎08-02-2007

Re: AXI Quad SPI transfer width problem

Jump to solution

Hi,

 

I have run a quick simulation with 2014.1 and it seems to be fine.

 

I believe that this issue is already fixed in 2014.1

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
5 Replies
Highlighted
Explorer
Explorer
5,248 Views
Registered: ‎09-03-2013

Re: AXI Quad SPI transfer width problem

Jump to solution

We also used AXI Quad SPI IP in standard transfer mode at 16 bits transaction. In testing we get only 15 clock cycles ....strange.

 

 

0 Kudos
Highlighted
Explorer
Explorer
4,820 Views
Registered: ‎09-03-2013

Re: AXI Quad SPI transfer width problem

Jump to solution

Anyone has any idea from this issue?

 

 

We have done our 32-bits long SPI transfers with four 8-bits transfers and keeping slave select low all the time with SW. Anyway it would be nice to have a solution/comments on this.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
4,812 Views
Registered: ‎08-02-2007

Re: AXI Quad SPI transfer width problem

Jump to solution

Hi,

 

This is a known issue with the IP and is scheduled to be fixed in 2014.1

 

However you can try using the 8-bit mode, this was able to work as expected.

 

--Hem

 

 

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Explorer
Explorer
4,809 Views
Registered: ‎09-03-2013

Re: AXI Quad SPI transfer width problem

Jump to solution

OK. 2014.1 is already published....I have not installed it.

 

Do you mean that this is ALREADY corrected in 2014.1 ....or scheduled to be fixed in some future release?

 

:)

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
6,384 Views
Registered: ‎08-02-2007

Re: AXI Quad SPI transfer width problem

Jump to solution

Hi,

 

I have run a quick simulation with 2014.1 and it seems to be fine.

 

I believe that this issue is already fixed in 2014.1

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos