cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Visitor
Visitor
314 Views
Registered: ‎01-02-2020

BOOT.bin does not work with ZC7045

The chip is 7045 and the platform is vivado 2018.4. Using the FSBL, bitstream file and u-boot.elf in the SDK to generate BOOT.bin, it does not work properly (no print information output), and the BOOT.bin generated after removing the bitstream file does work properly . I also tried to use FSBL, bitstream file and hello.elf to generate BOOT.bin, which also cannot work normally (no print information output). BOOT.bin generated after removing the bitstream file can work normally.

This is the IP configuration,only uart and nand flash are used in vivado.

ppps.jpg

 

I can't find the problem and hope to get help.

0 Kudos
Reply
1 Reply
Xilinx Employee
Xilinx Employee
227 Views
Registered: ‎07-12-2018

Hi @gwei ,

 

Could you please confirm the version of the Vivado? Also could you attach the screenshot of the design or the bd tcl file?

Did you try loading the bitstream from the SDK directly? I mean whether you have verified running the FSBL, Bitstream.

Best Regards
Abhinay PS
------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------

0 Kudos
Reply