UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant ilya1976
Participant
6,459 Views
Registered: ‎04-07-2014

BSP building Error on SDK

Dear Support,

I am following the document UG980 "Board Bringup Guide" to build BSP for the ZC702 evaluation board on SDK 2013.4.

When I try to build Petalinux BSP project, I get the following error:


ERROR:EDK - petalinux () - can't read "env(PETALINUX)": no such variable
make: *** [ps7_cortexa9_0/lib/libxil.a] Error 2
ERROR:EDK - Error(s) while running DRCs.
make: Target `all' not remade because of errors.


Please help to solve the issue.

Thanks in advance
0 Kudos
4 Replies
Contributor
Contributor
6,122 Views
Registered: ‎10-07-2014

Re: BSP building Error on SDK

Hi,

 

I'm also facing the same issue while building Petalinux BSP for KC705 platform. I'm using Petalinux SDK version 2013.04.

 

Error:

 

make -k all
libgen -hw ../petalinux_hardware_hw_platform/system.xml\
-lp G:/LINUX_SHARE/hardware/edk_user_repository\
-pe microblaze_0 \
-log libgen.log \
system.mss
libgen
Xilinx EDK 14.7 Build EDK_P.20131013
Copyright (c) 1995-2012 Xilinx, Inc. All rights reserved.

Command Line: libgen -hw ../petalinux_hardware_hw_platform/system.xml -lp
G:/LINUX_SHARE/hardware/edk_user_repository -pe microblaze_0 -log libgen.log
system.mss


Staging source files.
Running DRCs.
#-------------------------------------------------

# Top Level BSP DRC for Petalinux...

# Created by: Michal Simek

# version: petalinux_v2_00_a

#-------------------------------------------------

Windows

ERROR:EDK - petalinux () - can't read "env(PETALINUX)": no such variable
ERROR:EDK:3414 - Error(s) while running DRCs.
make: *** [microblaze_0/lib/libxil.a] Error 2
make: Target `all' not remade because of errors.

 

Any help will be appreciated.

 

-- mayankara

0 Kudos
Community Manager
Community Manager
6,119 Views
Registered: ‎06-14-2012

Re: BSP building Error on SDK

Hi

Please see the following theards. It might be helpful.

 

http://forums.xilinx.com/t5/Embedded-Linux/EDK-ERROR-petalinux-bsp-build/td-p/433672

 

Regards

Sikta

0 Kudos
Contributor
Contributor
6,111 Views
Registered: ‎10-07-2014

Re: BSP building Error on SDK

Hi Sikta,

 

Actually I build Petalinux SDK (v2013.04) on Ubuntu 14.04 (64-bit machine) running as virtual machine on windows7 (64-bit) host. I followed the steps mentioned in ug980 pdf.

 

I tried the steps asmentioned in the link also. Still struggling with the same error.

 

-- mayankara

0 Kudos
Newbie simon_tseng
Newbie
4,634 Views
Registered: ‎06-29-2015

Re: BSP building Error on SDK

i have the same problem, did you found any solution?

0 Kudos