Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎10-18-2018

[BUG] Xilinx SDK 2018.3 cuts off the FTDI serial connection on Linux


Facing this issue from time to time since last week. Launching an application (e.g "secure key driver") which uses serial connection disconnects the board's serial interface on a JTAG boot mode selected board. The same happens when "Program Flash" option is tried on a QSPI boot mode selected board.

I have my cable drivers insalled correctly, and my udev rules are correct; since it does not occur everytime.

Dmesg logs after running a program on XSDK:

[33013.637715] cdc_acm 1-3.4:1.0: ttyACM0: USB ACM device
[33028.969849] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
[33028.969881] ftdi_sio 1-3.3:1.0: device disconnected


Linux Distro: Ubuntu 16.04
Kernel: 4.15.0-45-generic
Xilinx SDK 2018.3 (also the same issue with 2017.1)
SoC: Zynq 7020
Board: Both ZedBoard and a custom board suffer from the issue
Cable: FTDI FT232



0 Kudos
2 Replies
Registered: ‎10-18-2018


Update - XSDB: Manually downloading the binary into the PS using XSDB cuts off the connection, too.



Tags (2)
0 Kudos
Registered: ‎10-18-2018

Seems like it is not an UART issue. The device that looks like disconnecting is actually the programmer (JTAG) which uses FTDI chip and changes it's mode to program the board; which looks like a disconnection to the host side. Most of the time I don't get any output so it made me think like it was an UART problem.

For now, it looks like this is not a bug. However, hopefully I'll go on using the boards and if I don't notice a no-UART-output case I'll mark this reply as solved.

0 Kudos