UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
1,499 Views
Registered: ‎04-23-2013

Board Support Package Settings does not show alternative driver versions

Hello,

I am having trouble with iicps V3.3, which has an unresolved include or something.

I wanted to try rolling back the iicps version to see if it went away.

 

When I go to Xilinx Tools / Board Support Package Settings / drivers, I see the iicps driver set at V3.3.

When I click the drop-down, the only version available is 3.3.

I checked my SDK install and there are other versions if iicps there.

 

Is there another way to do this?

 

Thanks,

Emmett

 

0 Kudos
6 Replies
Moderator
Moderator
1,486 Views
Registered: ‎08-25-2009

Re: Board Support Package Settings does not show alternative driver versions

Hi, I think you can change the version directly in system.mss file and re-generate BSP.
"Don't forget to reply, kudo and accept as solution."
0 Kudos
Explorer
Explorer
1,459 Views
Registered: ‎04-23-2013

Re: Board Support Package Settings does not show alternative driver versions

Hi Nanz,

Thanks for your reply.

I tried manually editing the mss.

I then exported hardware and launched SDK from VIvado.

The SDK project was messed up and would not load the source windows, etc.

I forget what the error message said.

 

Is this the way to go about it?

 

Thanks,

Emmett

0 Kudos
Moderator
Moderator
1,428 Views
Registered: ‎08-25-2009

Re: Board Support Package Settings does not show alternative driver versions

Hi Emmett, why you have to export the HW and launch SDK after changing system.mss? In SDK BSP, there is a source tab which you can view the system.mss, and you can change this to the version that you want. Then, you can rebuild BSP in SDK and the sw application.
"Don't forget to reply, kudo and accept as solution."
Explorer
Explorer
1,412 Views
Registered: ‎04-23-2013

Re: Board Support Package Settings does not show alternative driver versions

Hi Nanz,

Thanks for your reply.

I think what you are describing is where I started.

The only driver version in the dropdown is 3.3.

When I manually edit the mss, SDK does not like it.

Maybe it does not recognize the lower versions, but they are installed.

See attached.

Thanks,

Emmett

 

 

mss.jpg
0 Kudos
Moderator
Moderator
1,409 Views
Registered: ‎08-25-2009

Re: Board Support Package Settings does not show alternative driver versions

If you go to the Source tab, and change the version, you should be able to rebuild. Then if you go back to the dropdown list, you can also see this old version. Does it not work the same for you? Where did you change the system.mss file?

"Don't forget to reply, kudo and accept as solution."
Capture.JPG
0 Kudos
Explorer
Explorer
1,407 Views
Registered: ‎04-23-2013

Re: Board Support Package Settings does not show alternative driver versions

I just tried:

1. manually editing the mss to V3.1

2. Modifying the mss from the sources tab, where the V3.1 was shown as active.

3. BSP re-generated.

 

The project now runs (with the rolled-back iicps version, I assume).

 

However, my original problem remains.

Can't find a source file at "/proj/esdt_sdk/gnu_abe/ABE/builds/win/arm/arm-none-eabi/snapshots/newlib.git~linaro_newlib-branch/newlib/libc/stdlib/exit.c"
Locate the file or edit the source lookup path to include its location.

 

Thanks,

Emmett

0 Kudos