UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
3,844 Views
Registered: ‎11-25-2009

Bug? SDK - (re)program FPGA

Hi all,

 

Since I'm using SDK (now updated to the 11.4 version) I have some problems reprogramming the FPGA after a board re-boot by the "Program FPGA" button. I found 2 workarounds for this (see below), but I hope someone found a more handy solution since this is pretty annoying. This is the main issue I observed:

 

-----------------------------------------------------------------------

- I have SDK on

- I turn on the SP605 board

- I click the Program FPGA button -> download is ok

- I program the soft

 [then I do something with the board]

- now I need to turn the board off

 

 and I see a bunch of messages in the XMD console:


Info:write cmdbuffer failed 2000000F.
Info:write cmdbuffer failed 2000000F.
Info:write cmdbuffer failed 2000000F.
Info:write cmdbuffer failed 2000000F.

 

- when I turn the board on again, I am still "spammed" by these messages, and re-program just doesn't work (cannot connect to cable message)

-------------------------------------------------------------------------------------------------------------------------

Workaround1:

switch SDK to the same workspace (reboot the workbench)

 

Workaround2:

 Turn on Project Navigator and reprogram the board by ISE (since in my case it is a ProjNav based project). Then download SW works correctly from SDK

-------------------------------------------------------------------------------------------------------------------------

 

 

I suppose that the programming script is more efficient in ProjNav, since it never fails, and I wonder why the same script is not used from within SDK?? How can the SDK programming script be customized? Mavbe a future release of SDK will target this issue?

 

Has someone else encountered this issue?

 

 Thanks in advance for your feedback, which is really appreciated,

 

Michele

 

Tags (3)
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
3,821 Views
Registered: ‎08-07-2007

Re: Bug? SDK - (re)program FPGA

Hi,

 

The info message is from debugging tool XMD, not from configuration tool iMPAC. 

 

It seems that when turning off the board, the CMD is still connected to the baord. Sicne theboard is off, XMD can't  access itany more, thus the "info".

 

Have you tried exit the XMD in it's console? Or probably a better way is to make sure that you quit the debug/run session in SDK before turining off the board?

 

-Felix

0 Kudos
Highlighted
Adventurer
Adventurer
3,805 Views
Registered: ‎11-25-2009

Re: Bug? SDK - (re)program FPGA

Hi Felix,

 

Thank you for your reply :)

 

>  It seems that when turning off the board, the CMD is still connected to the baord. Sicne theboard is off, XMD can't  access itany more, thus the "info".

 

You are right, but still, once I've turned the board on, from ProjNav I can program the FPGA, (and this kind of "restores" SDK's XMD). Instead, if I use SDK only, I still cannot find how to reset XMD.

 

> Have you tried exit the XMD in it's console?

 

What is the quickest way to do this? The only one I found is to restart the whole SDK, hopefully there's a direct command? Since closing and re-opening the view has no effec, the "reset system" button on the top left just freezes the whole application so that I have to kill it throught the task manage...

 

Kindly,

 

Michele

 

0 Kudos