cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
paulmtcuk
Visitor
Visitor
2,937 Views
Registered: ‎01-29-2019

Bug? executables selected for download following on to the following processors doesn't exist or incorrectly specified

Vivado v2018.3 64-bit 

I made some changed to my program in the SDK and compiler was complaining that there wasn't enough space for heap, so I closed the SDK, increased the amount of BRAM from 16K to 32K in the Address Editor (Block Design), saved, rebuild bit file, programmed, exported hardware with bitstream included and restarted SDK. I instead created a new "Hello World" project (because I have done this before and I ended up getting include errors so I made a new SDK project which solved it) but this time no compiler errors, I just got this error on "Run" or "Debug"

"executables selected for download following on to the following processors doesn't exist or incorrectly specified. Do you wish to ignore them and process? 1. microblaze_0"

I found nothing about this error on Xilinx web page or documentation. I can't find very much information about this error online either. I can't understand how it thinks the processor doesn't exist if it exists in the block design as "microblaze_0" and device has been programmed, hardware exported with bit and a even just a new project created? Obviously the code does not run.

Edit:

The only way I managed to solve this problem was by deleting the whole .sdk folder as suggested by on search, (deleting all sdk projects and configurations) -- which means I need to make a new SDK application project and fill it again. After choosing "Run", this time I get an option to choose "Launch on Hardware" which I didn't get before. Bug?

Edit 2:

I found that you have to explicitly set Run As / Debug As --> Launch on Hardware , otherwise if just selecting Run/Debug might come up with this error

Tags (2)
0 Kudos
2 Replies
MartinF
Newbie
Newbie
1,545 Views
Registered: ‎08-12-2020

Hi there,

I observed the same behavior in my SDK after copying and changing a project within the same workspace.

Even clean build and deleting Debug folder did not solve the problem.

 

In the very end it was solved by "refreshing" the project (select project and press F5 key) after build.

So it might be some kind of "out-of-sync" problem....

 

Best regards and take care

Martin   

0 Kudos
1,059 Views
Registered: ‎11-13-2020

I guess,maybe you forget to click "Built"?you didn't compile after you changed it. that's a button like a hammer. 

0 Kudos