cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
analogital
Observer
Observer
268 Views
Registered: ‎04-11-2019

Can't build any project in xilinx sdk

Hi all 

I found a strange problem, unable to compile the project with xilinx SDK.

When I use xilinx sdk 2015.4 or 2019.1 to compile the project, I always encounter the same problem show as figure below,so i can't build any project.

Now i can’t use any version of the Xilinx SDK to continue the development of zynq PS , can anyone tell me how to solve this problem?

 

Tags (1)
Snipaste_2021-03-14_23-30-41.png
0 Kudos
4 Replies
joancab
Advisor
Advisor
246 Views
Registered: ‎05-11-2015

I see, for example, you have two platform projects. That's not a problem but I found myself that a number of times when updating the hardware from Vivado instead of updating the platform it creates a new one and is not clear whether the rest of project (bsp and app) will be using. In that case I use to restart a new project just reusing the sources.

Besides that, SDK, like Vivado and actually almost any software tool sometimes get some file corrupted and its state is irrecoverable. Mixing different SDK releases over the same project can make things just worse.

Have you tried starting again from scratch with the software sources?

0 Kudos
analogital
Observer
Observer
210 Views
Registered: ‎04-11-2019

Hi joancab

Thank for your answer.

I use vivado2015.4 and 2019.1 to build the same zynq project, and then use Xilinx SDK2015.4 and 2019.1 to compile the project ,SDK will report the same error as picture show.

I try uninstalled all the vivado on my computer, and then reinstalled vivado2019.1. When i build new zynq project and using SDK to develop ps project it's still can't build. SDK reported the same error

0 Kudos
analogital
Observer
Observer
169 Views
Registered: ‎04-11-2019

Now i can't build any zynq ps project,The sdk is stuck on compiling, and the CPU usage is also relatively high.

Snipaste_2021-03-15_14-30-03.png
0 Kudos
joancab
Advisor
Advisor
155 Views
Registered: ‎05-11-2015

I see two possibilities: 
1. The project is corrupted so it won't work with any release or any machine. As you say "I can't compile any project" Do you mean any other besides these three in that workspace? (that's one project to me). Then it's something else.
2. The environment is broken. You reinstalled SDK. But uninstalling usually leaves 'things'. The compiler itself should have been replaced but who knows what else SDK is using? (those infamous cherry picked redistributable libraries, etc.).

 

0 Kudos