cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
qwaserdf-@._
Visitor
Visitor
3,073 Views
Registered: ‎06-14-2018

Can't print anything to SDK terminal

Jump to solution

The steps I followed:

 

Create a block diagram, add the zynq processor, double click on it and apply pynq presets (mine is zybo z7, but the FPGA is the same, XC7Z020-1CLG400C) and run the connect automation.

 

Create wrapper, generate bitstream and export hardware with bitstream included.

 

Launch SDK from Vivado. Create a new application project, hellow world. Everything like default.

 

Program FPGA, and run as launched on hardware.

 

I have checked every baud rate for every com port available. Nothing appears on the terminal. I also try print, as well as printf or xil_printf.

 

My version of vivado and SDK 2017.1 and my system is Windows 10.

 

I would appreciate any help.

 

Best regards.

0 Kudos
1 Solution

Accepted Solutions
madhu.mami60
Explorer
Explorer
3,297 Views
Registered: ‎06-19-2015

Hi,

 

"I have checked every baud rate for every com port available."....

 

Why you are checking all comports?? Are you not sure which comport is to your board? Have connected your board to PC Comport or not?

 

If your all connections are ok, pls use anyother comport terminals like TerTerm. Download it here.

 

Thanks

Madhu

View solution in original post

0 Kudos
4 Replies
madhu.mami60
Explorer
Explorer
3,298 Views
Registered: ‎06-19-2015

Hi,

 

"I have checked every baud rate for every com port available."....

 

Why you are checking all comports?? Are you not sure which comport is to your board? Have connected your board to PC Comport or not?

 

If your all connections are ok, pls use anyother comport terminals like TerTerm. Download it here.

 

Thanks

Madhu

View solution in original post

0 Kudos
pvempati
Xilinx Employee
Xilinx Employee
3,025 Views
Registered: ‎01-03-2017

Hi,

 

 

Can you check your BSP settings STDIN and STDOUT parameters?

 

Double click on MSS file which is available in BSP project and then click on Modify BSP settings. and check the STDIN and STDOUT parameters. Based on that we can tell the issue.

 

 

bsp1.png
0 Kudos
qwaserdf-@._
Visitor
Visitor
3,012 Views
Registered: ‎06-14-2018

This did it.

 

Really really apreciatted. And If you could explain the reason why it didn't work in SDK but I did in Tera Term I would have a debt with you.

 

Best regards.

0 Kudos
madhu.mami60
Explorer
Explorer
3,000 Views
Registered: ‎06-19-2015

Hi qwaserdf-@._

 

I dont know how exactly windows OS runs. I faced the similar issue with Xilinx SDK terminal. Sometimes it works fine, sometimes not.

I guess, SDK terminal runs on top of Xilinx SDK's software, Other terminals directly runs by windows OS. In your case, the windows OS not driving the data to SDK Terminal. Or it could be a bug from Xilinx SDK's terminal.

 

Hope my answer satisfies you... 

 

Thanks

Madhu