UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply
Accepted Solution

Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

Observer
Posts: 25
Registered: ‎10-25-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

@htsvn 

 

So can I, but only on one of my machines. I don't know what causes this bug but three different people have it.
Please ask the guy who wrote the parser for the clock configuration GUI in which cases the invalid clock range -1 : -2 is used.

Scholar
Posts: 869
Registered: ‎05-06-2012

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

Can you make sure your regional settings are set to US.
Observer
Posts: 25
Registered: ‎10-25-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)


stephenm wrote:
Can you make sure your regional settings are set to US.

That's it! Thank you. Here are my modified desktop entries ( ~/.local/share/applications/ ):

Vivado 2014.2:


[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=Vivado 2014.2
Comment=Vivado 2014.2
Icon=/opt/Xilinx/Vivado/2014.2/doc/images/vivado_logo.png
Exec=bash -c "export LC_NUMERIC=en_US.UTF-8 && /opt/Xilinx/Vivado/2014.2/bin/vivado" 


Vivado 2014.3:

 

[Desktop Entry]
Encoding=UTF-8
Type=Application
Name=Vivado 2014.3
Comment=Vivado 2014.3
Icon=/opt/Xilinx/Vivado/2014.3/doc/images/vivado_logo.png
Exec=bash -c "export LC_NUMERIC=en_US.UTF-8 && /opt/Xilinx/Vivado/2014.3/bin/vivado" 

Moderator
Posts: 2,753
Registered: ‎08-02-2007

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

Hi Xilin

 

It looks that setting up the regional settings to US did resolve the issue.

 

Can you mark this post as solved?

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Observer
Posts: 25
Registered: ‎10-25-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

@htsvn I'm not the OP ( @abdullah.tukl is ) , can I mark it as a solution anyway?

Visitor
Posts: 21
Registered: ‎04-26-2013

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

@Xilin: Thanks for following this thread, as I didnt notice it was being replyed (didnt have subscription before)and I forgot that i even had created this thread. I solved this issue in a wierd way, I went to advanced configuration settings of clocks and changed the divider parameters.

 

@htsvn  Thanks to you for solving this issue. I would try changing regional settings to US

 

Visitor
Posts: 2
Registered: ‎12-06-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

Hi guys,

 

I experience the same error on my Linux system. As soon as I touch one of the fabric clocks the value turns red and I cannot apply the changes due to some validation/ out of range error. Changing the regional settings seemed to work for you.

Does anyone know how to fix this on Linux (64 bit and Vivado 2014.3)?? I have tried to include this export region line in my bash, but this doesn't work for me. Maybe I did it wrong.

 

I'd appreciate any suggestions.

 

 

 

Observer
Posts: 25
Registered: ‎10-25-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

@laminat Which distribution do you use?
What happens after you type

 

bash -c "export LC_NUMERIC=en_US.UTF-8 && /opt/Xilinx/Vivado/2014.3/bin/vivado"

 

into your shell?

 

 

I have attached the starter with the above line. Can you start Vivado with that?

Visitor
Posts: 2
Registered: ‎12-06-2014

Re: Cannot Set specific clock frequency for PL Fabric Clocks in Vivado 2014.2(Error Window shown in JPG)

Thanks Xilin,

 

it works. What a hack! :) I'm running Vivado 2014.4, I edited the paths.

 

Thanks again!