UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor asanka1984
Visitor
1,911 Views
Registered: ‎06-13-2014

Cannot debug into static library

Hi

I created a C++ project of type "XIilinx Arm linux Executable". And then we added a static library of type "Xilinx Arm Linux Static Library" which contains a simple "Add" function. And inside the main application we called the "Add" function from main application. Everything worked fine and messages to stdout are also desplayed. 

 

The problem arouses when we try to debug the code. The breakpoints which are set inside the main application are hit normally during the debugging process. But when we place a breakpoint inside the code of static libraray those breakpoints goes ignored. But we can debug into static library source code starting from main application breakpoint. So this might not be a problem with static libraray not generating debug information.

Upon investigating problem we managed to find follwing things. 

1. When we place a breakpoint in main application source, a log is generated in GDB console specifying that a breakpoint is added. But when we place a breakpoint in static library source such log is not added to GDB console.

2. We added a breakpoint to static libraray source via GDB command line. Surprisingly that breakpoint worked without any issue. So what we can suspect is that the breakpoints which are added inside static library are not generating releavant GDB commands. 

 

The workspace we used to test this scenario is attached. 

We created the main application using : File->new project->C++ project-> Xilinx arm linux executable

We created the static library using :  File->new project->C++ project-> Xilinx arm linux static library 

 

From Xilinx Software development kit -> about

xilinxAbout.png

 

 

0 Kudos