cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Newbie
Newbie
8,272 Views
Registered: ‎12-20-2012

Cannot find -lxil

I am attempting to run through the the hello_world tutorial from Zynq Concepts, Tools and Techniques. However in the SDK I get the error:

 

**** Build of configuration Debug for project hello_world_0 ****

make all
Building target: hello_world_0.elf
Invoking: ARM gcc linker
arm-xilinx-eabi-gcc -Wl,-T -Wl,../src/lscript.ld -L../../hello_world_bsp_0/ps7_cortexa9_0/lib -o"hello_world_0.elf" ./src/helloworld.o ./src/platform.o -Wl,--start-group,-lxil,-lgcc,-lc,--end-group
c:/xilinx_embedded/14.2/ise_ds/edk/gnu/arm/nt64/bin/../lib/gcc/arm-xilinx-eabi/4.6.1/../../../../arm-xilinx-eabi/bin/ld.exe: cannot find -lxil
collect2: ld returned 1 exit status
make: *** [hello_world_0.elf] Error 1

 

I believe its an error with the linker but I cant seem to find a fix for it. Any Ideas?

 

Thanks in Advance

Tags (1)
0 Kudos
Reply
6 Replies
Visitor
Visitor
8,177 Views
Registered: ‎10-03-2012

Similar problem here. 

 

It is very tiring to say the least that Xilinx should do more QA on their software tools and environment before releasing.

 

Anyway, does anyone have a way to get around this error?

 

Description         Resource             Path       Location              Type

cannot find -l-Wl,--start-group,-lxil,-lgcc,-lc,--end-group   hello_usb_0                                     C/C++ Problem

make: *** [hello_usb_0.elf] Error 1           hello_usb_0                                     C/C++ Problem

0 Kudos
Reply
8,043 Views
Registered: ‎03-04-2011

Same problem here - 14.5 on Windows 8. Any solution? thanks

0 Kudos
Reply
Visitor
Visitor
7,985 Views
Registered: ‎05-01-2013

 

I had this problem, fixed it.

 

I was following along with an "LEDController" tutorial that included a hello_world component.  Part of it got interrupted due to another issue so I was stuck with a non-compiling project.  I noticed the standalone_bsp_0 project was not compiling either but wasn't sure how to get that fixed.

 

So I saw there was a Makefile, went out to the command prompt, ran "make" in this directory (your directory name will be different do I made these names generic) ...

 

myhomedir/xilinxProjects/MyProject/MyProject.sdk/SDK/SDK_Export/standalone_bsp_0

 

Doing that successfully is what builds the libxil.

 

Then I went back into the SDK and right-clicked the hello_world_0 project and selected "Build", it was able to find libxil since it existed now.  The build finished.

 

I'm running the tools on Linux Mint which is a derivative of Ubuntu.

 

Newbie
Newbie
5,039 Views
Registered: ‎08-18-2015

just found out,

 

you better manually edit the objects.mk file.  all problems were there. Eclipse doesn't handle well creation of that file :P

0 Kudos
Reply
Observer
Observer
2,678 Views
Registered: ‎06-01-2018

I had the same problem on SDK 2018.1 when importing existing projects.

Building the BSP-project failed because auf missing -lxil file.

 

Finally all I had to do was right-click on the hardware project and do a Refresh (F5).

After that the bsp- and all application projects automatically compiled without error.

Newbie
Newbie
433 Views
Registered: ‎11-01-2020

To provide a more complete answer, richnsim is mostly correct.

If you get this error, it's because you're missing the "XILFFS (Generic Fat File System Library)" library option inside of your board support package [BSP], or it hasn't been generated.  If you have this option enabled already, you will need to regenerate your BSP.  You can do this by right clicking on the BSP folder and clicking "re-generate BSP source" from the drop down menu.  Or, you can open the system.mss file and click the "Re-generate BSP Sources" that appears in the window at the top.

However, you will need to have this already enabled in the BSP, if you haven't already.  To do this, you can open the system.mss inside the BSP and click "Modify this BSP's Settings" at the top.  You'll get a pop-up that with the title "Board Support Package Settings."  Inside of this, you'll have a table in the section labled "Supported Libraries."  You'll want to check the box next to "xilffs".  Press OK and it should regenerate the sources soon afterwards.  This fixed the issue for me and I was able to continue with my project.

I made these directions using:

Xilinx Software Development Kit

Release Version: 2018.2