cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
413 Views
Registered: ‎09-22-2009

Cannot find the EDK in the 14.7_VM

Hi all,

I need to reopen old Spartan6-Designs with µ-Blaze with the 14.7 ISE / virtual machine under WIN10.
now I have 2 problems for which I can't find a solution:

1.: I can only start the ISE Project Navigator and can't find the EDK to create a new netlist.

2.: If I load the project in the ISE Project Navigator I get a lot of "Locate Missing Source Files", all of them are basic elements of Xilinx like addsub.vhd, counter.vhd, etc.
I cannot find them within the 14.7 installation to relocate them.
Does anyone knows this path?

Thanks

0 Kudos
6 Replies
Highlighted
Teacher
Teacher
380 Views
Registered: ‎07-09-2009

Re: Cannot find the EDK in the 14.7_VM

I think the pre packaged ISE, is just that , ISE

EDK was / is an add on program,

My thought is if you need EDK, then you need to make your own VM with windows 7 on, or a compatible linux and install it yourself,

As for licencing, that might be your next problem as Xilinx have IMHO , dropped like a hot stone the EDK design route.
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
Highlighted
Visitor
Visitor
323 Views
Registered: ‎09-22-2009

Re: Cannot find the EDK in the 14.7_VM

Thanks
but this is not a solution.
All what I need is an option to change some bits in the VHDL in old SPARTAN6 designs.
The µBlaze design is unaffected

0 Kudos
Highlighted
Visitor
Visitor
302 Views
Registered: ‎09-22-2009

Re: Cannot find the EDK in the 14.7_VM: Additional problem

It seems that only the Web-Edition is running in the VM.
It is not possible to enter the path to the license server.
Only inormation: "Linux users will need to make these settings outside of this application"
I can't find where "outside" is.
If I go to System\Admin a password is required...
The VM is also limited to one of 28 CPUs and it is not possible to change this!

0 Kudos
Highlighted
Teacher
Teacher
293 Views
Registered: ‎07-09-2009

Re: Cannot find the EDK in the 14.7_VM: Additional problem

IMHO
this is a continuation of the long running problem Xilinx has made for themselves by dropping ISE in place of Vivado.

They decided at the beginning of vivado they would not update ISE, they got a kick back from big companies and those using CPLDs ( that Xilinx still sell in millions ) , so they kept patching ISE, but NOT make it work on Windows above 7.

When W7 was being phased out, they came up with a linux kludge , for the spartan 6 only, which half worked, and the un official recommendation was to use your own W7 machine, be that in a VM of your own, or preferably on a real machine,

When W7 was totaly dropped, they eventually decided to make ISE for all parts available as a linux on VM Kludge, that seems to work even worse.
I have not installed it myself, but I hear that you have now to install your own, admit ably free, oracal VM first, as opposed to the first Kludge they made when it was all distributed as one,

And still the CPLDs and spartan 6 need supporting for new designs, let alone those like yourself trying to work on legacy code.

If only they had decided to re compile ISE for W10 back in the day !

Ah well, Xilinx historic-lay wont listen to the users on the forums, only to those that spend millions in one hit with them, not the 10s of thousands that spend a few thousand with them,

My advice, find a machine that you can put W7 on, take it off the network, and use that. Luckily the anti virus manufacturers still seem to be supporting W7 even if Xilinx have stopped.

Then pray it does not break down ,

Good luck

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
Highlighted
Visitor
Visitor
282 Views
Registered: ‎09-22-2009

Re: Cannot find the EDK in the 14.7_VM: Additional problem

Thank you for this input!
I believe that a real WIN7-PC would be the only option.
But for this I must wait to the end of Corona because this won't work with Home-Office...
Highlighted
Teacher
Teacher
262 Views
Registered: ‎07-09-2009

Re: Cannot find the EDK in the 14.7_VM: Additional problem

The best of luck to you
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>