UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mahkoe
Visitor
165 Views
Registered: ‎02-08-2019

Cannot open LWIP echo template because SDK doesn't recognize DRAM

Jump to solution

When I try to create a project from the LWIP echo server template in Vivado SDK, I get an error that there is not enough memory.

 

However, I know there is enough memory because I added an memory interface generator (MIG7) with access to external DRAM. I can open a hello world template and change the linker script to use the DRAM.

 

How can I get the LWIP echo server template to load?

0 Kudos
1 Solution

Accepted Solutions
Visitor mahkoe
Visitor
142 Views
Registered: ‎02-08-2019

Re: Cannot open LWIP echo template because SDK doesn't recognize DRAM

Jump to solution

I managed to solve my problem. I didn't realize that you need to enable an option in the microblaze conf.

 

Basically, on the last page of the microblaze IP ocnfuration, you can enable an AXI port for instructions. This should solve the problem

2 Replies
Visitor mahkoe
Visitor
143 Views
Registered: ‎02-08-2019

Re: Cannot open LWIP echo template because SDK doesn't recognize DRAM

Jump to solution

I managed to solve my problem. I didn't realize that you need to enable an option in the microblaze conf.

 

Basically, on the last page of the microblaze IP ocnfuration, you can enable an AXI port for instructions. This should solve the problem

Explorer
Explorer
128 Views
Registered: ‎05-25-2016

Re: Cannot open LWIP echo template because SDK doesn't recognize DRAM

Jump to solution
Thanks for posting the solution!
0 Kudos