cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
2,333 Views
Registered: ‎08-19-2013

Compact Flash issue

Jump to solution

Hello!

 

I'm trying to use Compact Flash for the first time. Firstly I created an Axi- based system with microblaze, SysAce Interface Controller (and all the other necessary IPs) in XPS 14.3. I exported my design in SDK and I succeded in reading the sectors of CF (just like the examples).

 

 

Unfortunately, I was not able to write sectors correctly and after many efforts, I decided to format the CF with Microsoft Windows format tool (selecting FAT for file system) (bad thing(?)) . Now I'm not able neither to read nor to write. The function XSysAce_Lock  always returns XST_DEVICE_BUSY.

 

Is this happening due to the format or is it something else? 

I'm using SP605. 

 

Thanks in advance!

Eleni

0 Kudos
1 Solution

Accepted Solutions
Highlighted
2,967 Views
Registered: ‎08-19-2013

Hello Hem,

 

Thanks for your reply! 

 

I re-formatted the CF with the "mkdosfs" formatting utility and everything works right now. 

The answer was here: http://www.xilinx.com/support/answers/14456.htm.

 

After that I followed your suggestion to restore the contents of Compact Flash.

 

Thanks a lot!

Eleni.

 

View solution in original post

0 Kudos
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
2,313 Views
Registered: ‎08-02-2007

Hi,

 

Can you check if restoring the CF card contents do help?

 

http://www.xilinx.com/support/documentation/boards_and_kits/xtp061.pdf

 

--Hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
2,968 Views
Registered: ‎08-19-2013

Hello Hem,

 

Thanks for your reply! 

 

I re-formatted the CF with the "mkdosfs" formatting utility and everything works right now. 

The answer was here: http://www.xilinx.com/support/answers/14456.htm.

 

After that I followed your suggestion to restore the contents of Compact Flash.

 

Thanks a lot!

Eleni.

 

View solution in original post

0 Kudos