cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
LPLA
Visitor
Visitor
740 Views
Registered: ‎07-24-2020

Console Output in SDK with hello world example

Hello,

 

this is my first time working with anything related to FPGA and Xilinx Tools.

Right now I am working with the ZedBoard (Zynq-7000 ZedBoard Zynq Evaluation and Development Kit).

So naturally I was trying some entry-level tutorials to get familiar with everything.

As you know there are quite a lot of tutorials online and I started with this one.

Unfortunately I do not own the 7-Segment Display so I only did the "turn on the LEDs by using the switches" part which worked just fine.

The next tutorials I wanted to do are this one,  this one and this one. 

In all three tutorials I got to the part where they run the "hello world" example but I never actually get the output on the console.

Trying some of the solutions I found like Help-Not-able-to-view-program-Output-on-the-SDK-Console or Vivado-2014-1-Hello-World or No-quot-Hello-World-quot-message-in-Terminal and some others didn't help.

 

I try to give as much information as possible and hope that someone can help me fix this:

Hardware

I am using the ZedBoard (Zynq-7000 ZedBoard Zynq Evaluation and Development Kit)

It is connected to my PC via USB (J14 UART and J17 JTAG)

 

Software

System is Scientific Linux 7.6 (Nitrogen)

Vivado v2017.2_sdx (64-bit) including SDSoc

Xilinx SDx v2017.2 (64-bit)

 

jtgcfg

$ djtgcfg enum
Found 1 device(s)

Device: Zed
Product Name: Digilent Zed
User Name: Zed
Serial Number: 210******742 (don't know if it's important to censor this)

 

$ djtgcfg init -d Zed
Initializing scan chain...
Found Device ID: 23727093
Found Device ID: 4ba00477

Found 2 device(s):
Device 0: ARM_DAP
Device 1: XC7Z020

 

In most of the tutorials they use Tera Term but I do not have it installed (but I do have PuTTY).

I tried connecting to the ZedBoard with Putty by using the IP and Port that the SDx showed me in the SDx Log which said: "connect -url tcp:127.0.0.1:3121"

For some reason I feel like this is not what I am looking for and I didn't get any output in the PuTTY console this way.

Hopefully someone has an idea what could be wrong.

Thank your for your help,

LPLA

Tags (3)
0 Kudos
2 Replies
ibaie
Xilinx Employee
Xilinx Employee
648 Views
Registered: ‎10-06-2016

Hi @LPLA 

Not sure if you already found the solution for your issue but there is a clear misunderstanding of the SDK log from your side

The "connect -url tcp:127.0.0.1:3121" message in the SDK log just means that the debugger has connected to the HW_Server running in your host machine (127.0.0.1) for loading/debugging the application, not that you need to connect there with Putty.

If you are using Putty instead of TeraTerm, you just need to open a serial port session (not ssh) using the right COM port in your host (you should be able to find it in the windows device manager) and the right baudrate (usually 115200).

Regards

 


Ibai
Don’t forget to reply, kudo, and accept as solution.
LPLA
Visitor
Visitor
614 Views
Registered: ‎07-24-2020

Hello ibaie,

 

thank your for your answer. I suspected that it was the IP of the host machine but it was the only information I could find.
I switched to a Windows machine and the newest version of Vitis. The included "hello world" example works fine on this machine.
As I mentioned the other machine does not use Windows but Scientific Linux 7.6 (Nitrogen) and an older version of Vivado (Vivado v2017.2_sdx (64-bit) including SDSoc) and the SDK (Xilinx SDx v2017.2 (64-bit)), so no Windows device manager on this machine.
For now I will keep using the Windows machine but sooner or later I might have to switch back to the other one.
I might also update my software to use Vitis but as of now I can't say for sure.

As soon as I get to verify your solution on the other machine I will mark it as the correct solution.



Regards,
LPLA

0 Kudos