UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor lida1204
Visitor
9,790 Views
Registered: ‎10-23-2007

EDK 8.1i : problem of generating .bin file ,for BPI booting

I use

promgen -w -p bin -c FF -o ff1.bin -u 0 download.bit

to generate the .bin file, and download it into NOR flash, but it can't boot up; the .bit is ok through JTAG download.

And the EDK I re-setup, for some system reason; in the former EDK 8.1i,,I do it well,but now i can't.
how to do with it?
0 Kudos
4 Replies
Explorer
Explorer
9,786 Views
Registered: ‎09-16-2007

Re: EDK 8.1i : problem of generating .bin file ,for BPI booting

Is this a custom board? I do it this way from CMD line

 

promgen -u 0x0 brassboard_top_download.bit -p bin –w 

 

If its custom board I have had trouble running Xilinx prom in series in the Master-Serial configuration mode.  Guessing by what you are trying to do the hardware ie NOR flash and it works correctly.  And you don’t have any need to get out your Oscilloscope and measure CCLK/D_IN/INT_B/PROG_B.   

 

Did you create a bootloader using the flash programmer? I have used the EDK flash programmer to program the boards using a bin file you just have to make sure you keep your address range small.  Also you have to define everything in the JTAG chain if its none Xilinx parts.  

 

Make sure that the boot loader is marked to initialized then change its linker script.  I think you have to change something from _boot to _start but not sure with out going to work and looking.  Oh after you see it work then you need to comment out debug in one of the .h files for the bootloader.  

 

PS EDK 9.1 works great EDK 9.2 is not ready for prime time so stay away from it if you are in detail design.

 

Cheers,

Bill Tomb

Cheers,
Bill Tomb
0 Kudos
Visitor lida1204
Visitor
9,776 Views
Registered: ‎10-23-2007

Re: EDK 8.1i : problem of generating .bin file ,for BPI booting

And now , I can do it  well on the testing PC ,which is storing the main projects and has been resetuped EDK 8.1i, 
for the same test project, this PC can boot up for both .bit and .bin;
and in other two PCs,setuped EDK 8.1i, .bit boot-up is ok, .bin can't;
comparing the .bit files,they have some differences..
0 Kudos
Highlighted
Visitor lida1204
Visitor
9,775 Views
Registered: ‎10-23-2007

Re: EDK 8.1i : problem of generating .bin file ,for BPI booting

and it is a custom board
0 Kudos
Explorer
Explorer
9,753 Views
Registered: ‎09-16-2007

Re: EDK 8.1i : problem of generating .bin file ,for BPI booting

Not sure what’s going on must be some settings or updates missing

 

 

Worst case

You could copy all the install files from the pc that works to the pc that does not.  Meaning go get a crossover cable and copy the entire EDK/ISE directory this should fix your problem.

 

Only do this if both machines run same processor.  Meaning Intel or AMD but they must be the same.

 

cheers,

Bill

 
Cheers,
Bill Tomb
0 Kudos