UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant nc6
Participant
4,412 Views
Registered: ‎05-07-2009

EDK 9.1 error in generate system.ace file

Hello All,

 

I am using 9.1 version of XPS and ISE with proper service packs. I recently bought a XUPV2P board and wanted to create a system.ace file for it using the above tools. I added the XUP board related files from the digilentinc website. The edk command shell in which i usually create the system.ace file gives me errors. I follow simple procedure (ref: BYU Linux) to create the system.ace file just the one i used to create for ML310 board, which works fine

 

Method::

xmd -tcl genace.tcl -opt xupGenace.opt

 

where the file xupGenace.opt contains the following:

-jprog
-board user
-target ppc_hw
-hw ../implementation/download.bit
-elf ../TestApp_memory/executable.elf
-configdevice devicenr 1 idcode 0x127e093 irlength 14 partname xc2vp30
-debugdevice devicenr 1 cpunr 1
-ace ../implementation/system.ace

The error appearing in the xygwin shell is (attachment 1 in the site)


I had another computer system in which i had loaded EDK 8.2 with proper Service Packs. I tried to generate system.ace in that one for the XUP board, and it worked. So I thought the problem was with the genace.tcl file of EDK 9.1 and replaced the genace.tcl file in EDK 9.1 with the genace.tcl of the EDK 8.2. Now it gave me another set of error (Attachment 2 in the site).
 

I would appreciate any thoughts on how to generate system.ace file using EDK 9.1 or if i am missing something really basic.

 

Please visit http://picasaweb.google.com/narashimanc/EDK_91#  for the pictures of the errors i am talking about. The attachment section in this forum isnt allowing me to attach two files together.

 

with warm regards,
chakra.
 

0 Kudos
2 Replies
Participant nc6
Participant
4,286 Views
Registered: ‎05-07-2009

Re: EDK 9.1 error in generate system.ace file

no solutions yet??
0 Kudos
Xilinx Employee
Xilinx Employee
4,272 Views
Registered: ‎08-07-2007

Re: EDK 9.1 error in generate system.ace file

Hi

 

I don't have 9.1 installed on my machine.  But I tried with 10.1. It works.

 

-XF

0 Kudos