cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor
Visitor
7,749 Views
Registered: ‎09-29-2009

EDK elfcheck failed!

 

  

Hi everybody!
I have downloaded the new ISE and EDK 11 and updated them to 11.3. 
I have noticed some changes in the way software projects are managed in SDK. 
My problem is the following: I have built my hardware platform succesfully (its a very simple one with just a couple of peripherals). The I export my hardware design to SDK. 
Once in SDK I create a software platform and after that a managed make c application project. I add my code and create the linker script. I get this error message one time after the other

************** Validating ELF File **************

Validating ELF Section Addresses with Hardware Address Map...
elfcheck -noheader -hw /home/jcgcecilia/Xilinx/projects/EDK/multiplier_test/SDK/SDK_Export/hw/system.xml -pe microblaze_0 mult.elf
ERROR:EDK:3165 - elfcheck failed!
The following sections did not fit into Processor memory:
Section .vectors.hw_exception (0x20 - 0x27)
Section .vectors.interrupt (0x10 - 0x17)
Section .vectors.sw_exception (0x8 - 0xF)
Section .vectors.reset (0x0 - 0x7)
      

Try using the linker script generation tools to generate an ELF that maps
correctly to your hardware design.
make: *** [mult.elf] Error 2

The thing is I can build and download to the FPGA he same project if a create the project i Software Projects inside XPS. 
I have tried several things without succes. I have googled it and nothing.

Any suggestion??

Thnaks in advanced

JC

Tags (3)
0 Kudos
3 Replies
Highlighted
7,734 Views
Registered: ‎08-21-2008

Re: EDK elfcheck failed!

Hello.

Which memory you are using for your soft code.

What is the size of that memory.

I think the size that you have specified for your memory is too small.

Try increasing the size of your memory. 

Best of luck.
--
Unlimited in my Limits.
0 Kudos
Highlighted
Newbie
Newbie
7,655 Views
Registered: ‎10-19-2009

Re: EDK elfcheck failed!

I ran into the same error building my application.  In my case it turned out the error was the base address of my instruction memory.  I had erroneously set it to some non-zero address.  Try the following:

 

  • Go back into XPS and set the base address for the ilbm_bram_cntrlr to 0x00000000
  • Rebuild the bitstream (Hardware->Generate Bitstream)
  • Re-export to the SDK (Project->Export ... to SDK)
  • Right click your application in the SDK and select "generate linker script"
  • click "OK".

 

 

If your error was the same problem, this should recompile your application and successfully build.

 

 

 

 

0 Kudos
Highlighted
Visitor
Visitor
7,165 Views
Registered: ‎07-27-2009

Re: EDK elfcheck failed!

In my case, I've increased the size of dlmb_cntrl and ilmb_ctrl from 16K to 64K and the error was resolved.

 

-Maaz 

0 Kudos