cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
akohan
Observer
Observer
2,743 Views
Registered: ‎01-23-2010

EDK versions and SDK!

 

Hello group,

 

I''m using few PDF files from Xilinx which are focusing on Spartan3E course in XUP. It seems the version they are discussing is 9.x or 10 and currently I'm using EDK 11.5

 

This is causing warning messages and  when I open old projects,  EDK claims it must update them but usually it ends up with errors and not able to convert them properly. What is the solution to this?

 

Also, sometimes while using EDK I get a message in its IDE that this or that method or feature are deprecated and I have to use SDK. What kind of software development kit is this?

and how and where can I learn about it?

 

 

Thanks,

Amit

 

 

 

 

 

Tags (5)
0 Kudos
1 Reply
htsvn
Xilinx Employee
Xilinx Employee
2,733 Views
Registered: ‎08-02-2007

Hi,

 

If you are trying to open a project in newer version that was built in older versions of the tools there might be some cores

 

that might have been deprecated/removed. So if the tool is not able to find those, we usually get some errors.

 

Usual recommendation would be is to build a BSB design in the EDK version that you have.

 

http://www.xilinx.com/support/documentation/sw_manuals/xilinx11/edk_ctt.pdf

 

SDK is the recommended development environment for software application projects

 

http://www.xilinx.com/tools/sdk.htm

 

Thnx.

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos