cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
8,486 Views
Registered: ‎10-08-2014

Error -1073741502 when ARM gcc compiler is invoked

Hello all

 

I have a problem when try to compile/build my project, I am working in Windows 8.1 computer and also have a windows 7 computer, I did the same process for the Xilinx SDK installation in both machines, but only in Windows 8.1 machine have this problem (I built the C program on the Windows 7 machine and worked perfectly):

 

error.PNG

 

 

I tried to run the SDK as administrator but got an Java error, any idea?

 

Thanks a lot.

0 Kudos
5 Replies
Highlighted
Xilinx Employee
Xilinx Employee
8,474 Views
Registered: ‎08-01-2008

The installer is not setting up the SDK environment properly when launching SDK from the PlanAhead tool.

To work around this issue, Launch SDK in standalone mode and not from the PlanAhead tool.
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,474 Views
Registered: ‎08-01-2008

 

Here is a possible workaround (at your own risk):

 

 

 

Make a copy the entire nt directory to nt64.

 

Relaunch SDK from planahead 64-bit.

 

Clean all projects and then rebuild. The libxil.a library will be recreated as part of the bsp project.

 

 

 

 

 

 

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,473 Views
Registered: ‎08-01-2008

This issue is due to the fact that the environment is not setup before SDK is invoked from the PlanAhead 14.4 or Vivado 2012.4 tool.
The environment SDK needs to function properly can be set by using the settings files generated by the installer.
When invoking PlanAhead and Vivado from program group/desktop shortcuts, the runtime environment is setup by the boot loaders and settings file are not used.

You can work around this problem by manually setting the SDK environment (e.g., run the settings32/64 .bat or .sh file).

In Vivado 2013.1 and PlanAhead 14.5 tool, this issue has been resolved by having the SDK boot loader construct an SDK runtime environment.
The Vivado boot loader will search the local install area ../../SDK/<same version as Vivado being used>. If SDK exists, set XILINX_SDK. If not, do not set it. No warnings, errors will be issued.
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,473 Views
Registered: ‎08-01-2008

To work around this issue, right-click on the BSP in the Project Explorer view in SDK, and select Build Project as shown in the image below:

Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Visitor
Visitor
8,456 Views
Registered: ‎10-08-2014

Well I am using Vivado 2014.2, I tried again with your responses but still not working, i think is like a denied access problem maybe, because it seem the error is something like that the SDK cannot create the object file, I mean, file with extension .o, I tried things like uninstall the Xilinx suit, and then install it again,but of course without any effect.

 

so, when you say NT directory which directory do you mean

 

the C:\Xilinx\SDK\2014.2\gnu\arm\nt ?

 

and copy all files in nt to C:\Xilinx\SDK\2014.2\data\xicom\cable_drivers\nt64 ?

 

Thanks for your response

0 Kudos