UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
4,241 Views
Registered: ‎02-12-2013

Error message when enabling shared memory (config_shm)

Jump to solution

In MSS I have the following enabled: systmr_spec, config_pthread_support, config_sched, config_time, config_sema, config_msgq (and use_malloc) and everything works just fine.

 

But when I enable config_shm I get the following error: "cannot find -lxilkernel"

 

How can I solve this problem?

 

Thanks,

0 Kudos
1 Solution

Accepted Solutions
Adventurer
Adventurer
5,669 Views
Registered: ‎02-12-2013

Re: Error message when enabling shared memory (config_shm)

Jump to solution
The problem was caused because I hadn't set the shared memory table size. Adding this line to the MSS solved the problem: PARAMETER SHM_TABLE = (4). I find the error message was misleading.
0 Kudos
3 Replies
Adventurer
Adventurer
4,236 Views
Registered: ‎02-12-2013

Re: Error message when enabling shared memory (config_shm)

Jump to solution
OK there's definitely a bug in SDK. I just went cleaned the project via project->clean and now I'm seeing this error: "sys/init.h" no such file or directory. When I remove sys/init.h in my code then it can't find xmd.h.
0 Kudos
Adventurer
Adventurer
4,233 Views
Registered: ‎02-12-2013

Re: Error message when enabling shared memory (config_shm)

Jump to solution
Here's the MSS of the working version:

BEGIN OS
PARAMETER OS_NAME = xilkernel
PARAMETER OS_VER = 5.01.a
PARAMETER PROC_INSTANCE = microblaze_0
PARAMETER STDIN = rs232_uart_1
PARAMETER STDOUT = rs232_uart_1
PARAMETER SYSTMR_SPEC = true
PARAMETER SYSTMR_DEV = axi_timer_0
PARAMETER SYSINTC_SPEC = microblaze_0_intc
PARAMETER CONFIG_PTHREAD_MUTEX = true
PARAMETER CONFIG_NAMED_SEMA = true
PARAMETER CONFIG_MSGQ = true
PARAMETER CONFIG_TIME = true
PARAMETER CONFIG_SEMA = true
PARAMETER USE_MALLOC = true
PARAMETER MSGQ_CAPACITY = 100
PARAMETER VERBOSE = true
PARAMETER DEBUG_MON = true
PARAMETER CONFIG_KILL = true
PARAMETER CONFIG_YIELD = true
END

And here's the MSS of the not working version:

BEGIN OS
PARAMETER OS_NAME = xilkernel
PARAMETER OS_VER = 5.01.a
PARAMETER PROC_INSTANCE = microblaze_0
PARAMETER STDIN = rs232_uart_1
PARAMETER STDOUT = rs232_uart_1
PARAMETER SYSTMR_SPEC = true
PARAMETER SYSTMR_DEV = axi_timer_0
PARAMETER SYSINTC_SPEC = microblaze_0_intc
PARAMETER CONFIG_PTHREAD_MUTEX = true
PARAMETER CONFIG_NAMED_SEMA = true
PARAMETER CONFIG_MSGQ = true
PARAMETER CONFIG_TIME = true
PARAMETER CONFIG_SEMA = true
PARAMETER USE_MALLOC = true
PARAMETER MSGQ_CAPACITY = 100
PARAMETER VERBOSE = true
PARAMETER DEBUG_MON = true
PARAMETER CONFIG_KILL = true
PARAMETER CONFIG_YIELD = true
PARAMETER CONFIG_SHM = true
END
0 Kudos
Adventurer
Adventurer
5,670 Views
Registered: ‎02-12-2013

Re: Error message when enabling shared memory (config_shm)

Jump to solution
The problem was caused because I hadn't set the shared memory table size. Adding this line to the MSS solved the problem: PARAMETER SHM_TABLE = (4). I find the error message was misleading.
0 Kudos