cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
4,130 Views
Registered: ‎11-13-2009

Error using EDK 9.2 reference design in EDK 11.1

I am currently using EDK 11.1 with a Spartan 3E starter board. The reference designs provided for this board are all for EDK 9.2. When I try to open these designs in 11.1, it tries to upgrade the project but gives a lot of errors like :

 

ERROR:EDK:467 - E:\spartan3-e\sp3e1600e_mb_bclinux\system.mss line 5 - Can not find MLD for the os standalone 1.00.a

 

ERROR:EDK:1552 - IPNAME:xps_mch_emc INSTANCE: FLASH - E:\spartan3-e\sp3e1600e_mb_bclinux\system.mhs line 231 - cannot find MPD for the pcore 

 

Please let me know a way to work around this

 

Thanks and Regards

 

Tushar Janefalkar 

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
4,119 Views
Registered: ‎08-02-2007

Hi,

 

Either you can replace line 5 in MSS with version 2.00a

 

like this

 

BEGIN OS
PARAMETER OS_NAME = standalone
PARAMETER OS_VER = 2.00.a

 

And the line 231 of MHS with the version number matching to the xps_mch_emc core version numbers available in the folder

 

 

$EDK_Install\hw\XilinxProcessorIPLib\pcores

 

 (Or)

 

You can create a new BSB project using the same components as in the MHS.

 

Thanx.

 

 

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Adventurer
Adventurer
4,097 Views
Registered: ‎01-16-2008

Hi

 

I do have the same problem. I have spartan 3 mini module. The reference design given are using OPB, in EDK11.1 I could not able to find OPB. By default it is taking PLB. 

 

The reference design given are using EDK 7.1 How to suceesfully upgrade to EDK 11.1.

 

 

Please Help me.

 

 

with regards

 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
4,086 Views
Registered: ‎08-02-2007

Hi,

 

OPB is deprecated starting from EDK_92. So  please create a BSB design using EDK 11.1.

 

This is because you have not set the option of seeing the deprecated cores.

 

You can set this up by going into Edit ==> Preferences ==> IP Catalog and Config. Therein you have the options to set the deprecated cores as well. Check all the options in that tab and you should see all the cores.

 

Check this too

 

http://forums.xilinx.com/xlnx/board/crawl_message?board.id=EDK&message.id=1081

 

Thanks

 

 

 

 

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Adventurer
Adventurer
4,069 Views
Registered: ‎01-16-2008

Hi hem,

 

When I try to upgrad, Some of the IP cores are not found. those are all have new version.

EDK gives following errors after upgradation

 

can notfind MDD for not upgraded drivers. I have attached the screen shot of not upgraded IP cores. 

Please find the attachment.

 

with regards

Screenshot.png
0 Kudos