cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
3,706 Views
Registered: ‎03-15-2009

Errors when using Microblaze/Spartan 3E project with cache enabled.

Jump to solution

Hi,

 

I'm obviously missing a step somewhere.  I'm trying create a Microblaze project using the base system builder for the Digilent Spartan 3E board.  I check the Enable box in Cache setup and then later check the ICache and DCache boxes for Micron_RAM.  Everything else uses the default values.

 

When I hit generate netlist I get the following errors:

 

ERROR:MDT - IPNAME:xps_mch_emc_digilent INSTANCE:Micron_RAM BUS_INTERFACE:MCH1 -
   D:\XilinxProjects\test4\system.mhs line 178 - invalid bus interface in use
   when ISVALID="(C_NUM_CHANNELS>=2)" evaluates to FALSE. Please remove the bus
   interface from your design!
ERROR:MDT - IPNAME:xps_mch_emc_digilent INSTANCE:Micron_RAM BUS_INTERFACE:MCH0 -
   D:\XilinxProjects\test4\system.mhs line 178 - invalid bus interface in use
   when ISVALID="(C_NUM_CHANNELS>=1)" evaluates to FALSE. Please remove the bus
   interface from your design!
ERROR:MDT - platgen failed with errors!
make: *** [implementation/microblaze_0_wrapper.ngc] Error 2

 

What step am I missing that causes this error?

 

Thanks

0 Kudos
Reply
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
4,329 Views
Registered: ‎03-15-2009

Found out the missing steps.  I located xapp923, which has the snappy title of "Reference System: MCH OPB EMC with OPB Central DMA".

 

You have to go to Ports->Micron Ram->Configure IP->Busses and increase the # of channels to 2.  For the Microblaze instance Ports->Microblaze->Configure IP->Cache and set the address range and other options.  Under the Bus Interfaces tab the Micron Ram XCL channels need to be stitched into Microblaze.

 

Thanks for the help.

View solution in original post

0 Kudos
Reply
2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
3,686 Views
Registered: ‎08-06-2007

Hi,

 

From the error messages it looks like the parameter C_NUM_CHANNELS for the xps_mch_emc isn't set to the right value.

It looks like it's set to 0 when it needs to be 2.

Check the value in the .mhs file and set it to the correct value.

 

Göran

 

0 Kudos
Reply
Highlighted
Visitor
Visitor
4,330 Views
Registered: ‎03-15-2009

Found out the missing steps.  I located xapp923, which has the snappy title of "Reference System: MCH OPB EMC with OPB Central DMA".

 

You have to go to Ports->Micron Ram->Configure IP->Busses and increase the # of channels to 2.  For the Microblaze instance Ports->Microblaze->Configure IP->Cache and set the address range and other options.  Under the Bus Interfaces tab the Micron Ram XCL channels need to be stitched into Microblaze.

 

Thanks for the help.

View solution in original post

0 Kudos
Reply