UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
6,279 Views
Registered: ‎02-12-2016

First project microblaze , errors i can't fix.

Hi all,

 

I am doing my first project in microblaze, and am trying to get a SPI slave working. I am trying to initialize the spi. and have no idea what will happend and what so ever but what better than just test it to learn it.

 

now did i get 5 errors which i am not completly sure i can fix, i think it relate to the two errors i am gonna describe

http://imgur.com/ZIiFEub

 

in the error list you can see the outbyte error, from what i read i should change te value of the SPI in- and output, but when i click on the value in the BSP setup i cant click anything there is nothing in the list.

 

the other error is the region error, it says that it is overflowed by 6000 bytes,

http://imgur.com/ZtvYQD0

 

as you can see i dont have that much in my block design (my opinion) and would have no idea how to reduce these bytes. Hope anybody can help me and point me in the right direction. 

 

Btw, i use the arty board.

 

Greetings,

 

Rowesca

 

 

0 Kudos
1 Reply
Adventurer
Adventurer
6,247 Views
Registered: ‎02-12-2016

Re: First project microblaze , errors i can't fix.

i made a smaller project and without spi and i don't get those errors, how comes the artix7a35t is so fast full?

0 Kudos