UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
15,540 Views
Registered: ‎06-02-2008

GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hello,

 

We have switched to ISE 10.1 as our design is now using a Virtex 5.

The debugging tools (either under SDK, or with the GDB run from the command line) have turned awfuly slow.

Even downloading the .elf file is slow: under XMD it is just a snap, with the SDK it takes almost 30 secs.

As for stepping, all the same.

Is there something wrong in my config I should be aware of?

 

Thx, Roland.

 

0 Kudos
1 Solution

Accepted Solutions
Visitor rehnmaak
Visitor
13,792 Views
Registered: ‎04-25-2009

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I have now applied the patches to the powerpc as well as the linux versions of gdb. I've not done much testing of the linux versions more than it do communicate with the target. The powerpc gdb is also slower than the microblaze when it comes to single line stepping, becase of the powerpc has to examine the stack frame before being able to set breakpoints when "stepping over calls".

 

I did some investigation how gdb is doing the single line stepping. It seem like it steps one machine instruction at a time until it reaches a call instruction where it puts a breakpoint just after the call instruction. I don't know why it just don't put a breakpoint at the next line. I'll have a look at the 6.8 version and see if it is any different.

 

I also had trouble with tk/tcl when running under linux. I had to comment a few lines in:

 

listbox.tcl lines 182-184

text.tcl lines 461-463

 

There are no instructions how to change and backup the files on linux so you are on your own. But as far as I understand just put the files in the /bin folder....

 

 ...and don't forget to leave feedback when you try them out.

 

 

http://rapidshare.com/files/250110867/mb-nt-gdb-6.5.0-lightning-speed-090630.zip

 

http://rapidshare.com/files/250111415/mb-linux-gdb-6.5.0-lightning-speed-090630.zip

 

http://rapidshare.com/files/250113194/ppc-nt-gdb-6.5.0-lightning-speed-090630.zip

 

http://rapidshare.com/files/250113764/ppc-linux-gdb-6.5.0-lightning-speed-090630.zip

 

 

63 Replies
14,208 Views
Registered: ‎09-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I concur - I have just upgraded from 9.1i (all SPs) to 10.1i (all SPs).

 

I tried running all four combos of 9.1i/10.1i GDB with 9.1i/10.1i XMD

and found 10.1i XMD to be the weak link w.r.t. speed.

 

Cheers,

Craig

0 Kudos
Xilinx Employee
Xilinx Employee
14,176 Views
Registered: ‎08-07-2007

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi Roland and Craig,

 

Are you guys using PPC or MicroBlaze? Does the code being downloaded into MPMC or BRAM? Did you try to debug the application out of BARM? Same behavior?

 

-XF

0 Kudos
14,089 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi together,

I have the same problem and I have posted it a while

ago (http://forums.xilinx.com/xlnx/board/message?board.id=EDK&message.id=5015#M5015),

but nobody replied at all.

 

The problem in short:

If I download a microblaze elf file (about 100k in size) to my S3E starter kit (SDRAM), it takes about 40s until

the debugger is ready. Stepping, breakpoints etc. respond also very slow.

If I do the same in SDK 9.2 the download takes about 6s, stepping etc. is OK.

 

If I do the download manually in the XMD console with "dow elffile" I cannot see

a notifiable difference in the time it takes (between V9.2 and V10.1).

Seems to me if there is a problem in the communication between GDB and the GUI.

 

 

 

 

 

 

 

 

Explorer
Explorer
14,088 Views
Registered: ‎08-29-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I had the same problem using the PPC440. The GDB transaction to the XMD was very slow.

I had to call the following set command  in the gdb shell:

"set processor powerpc:440"

but I'm not really sure whether this circumstance solves the issue!!!

0 Kudos
14,073 Views
Registered: ‎09-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hey XF - thanx for the contrib. I'm using uBlaze running from SDRAM - the code is way too big for BRAM.

I should also add that at this stage I am using 60-day trial license of EDK 10.1i - soon to be upgraded to full license. Is there possibly "go-slow" code for trial license?

0 Kudos
14,064 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I don't think it's a problem of the trial licence.

I'm using a full license and I have the same problem.

 

0 Kudos
Xilinx Employee
Xilinx Employee
14,055 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

In gdb, open up the console (View -> Console), and type:

 

(gdb) set download-write-size 4096
(gdb) set remote memory-write-packet-size 16384
(gdb) set remote memory-write-packet-size fixed

 

Then continue with your regular steps. This would definitely help with the download ELF speeds, but I'm not sure about the speed for other operations. Is the difference perceptible between the old and new versions for other operations also?

0 Kudos
Adventurer
Adventurer
14,045 Views
Registered: ‎08-16-2007

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

ralfcantnerbosch in post # 4 explained pretty well what the problem is and he compared with 9.2.

I notice the same problem and has become quite annoying.

The question here is why Xilinx is  continuing to screw-up things which were working (more or less) and more than this, why they don't bother re-fixing them in the SP's?

This is not the only thing that used to work and is not working properly anymore, although, we must admit, there are also improvements in some areas.

I feel this very frustrating as our (small) company invested money buying the tools, time in learning and so on.

Ben

0 Kudos
14,018 Views
Registered: ‎09-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Thanks for the input vsiva - it improved the download speed from 19972 bits/sec to around 49700 bits/sec.

However, this is still far short of the old download speed of 397596 bits/sec under EDK 9.1.02.

 

I tried the xmd  "dow <elffile>" option as well, but got about the same 49700 bits/sec load time - this seems contrary to the earlier post #4.

 

Craig

Message Edited by craigwoodhead on 09-24-2008 02:11 AM
Message Edited by craigwoodhead on 09-24-2008 02:13 AM
0 Kudos
Xilinx Employee
Xilinx Employee
15,250 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

For those of you who feel that the issue is in gdb, the above steps should help.

 

If you notice a slowdown in XMD itself, then I'd suspect that that the issue is in the cable drivers (drivers for XMD to board JTAG connection). In my tests with a parallel 4 cable, I did not see any slowdown. Should I assume that most of you are using a USB cable?

0 Kudos
Highlighted
Adventurer
Adventurer
15,244 Views
Registered: ‎08-16-2007

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I use parallel cable IV and I see the slow down. But not with XMD, only with gdb.

Used to work fine before 9.2 .

It is definitely and issue introduced in 10.1.

BR

0 Kudos
15,242 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi together,
I don't know if we all talk about the same.

 

Hi vsiva, you talk about gdb. Therefore I assume
that you mean the EDk software debugger. Sorry I'm
a newbie, it's hard for me to understand all the
abbrevations.

 

In post #4 I talked about debugging within the SDK (Eclipse).
The time I talked about in post #4 (SDK V9.2 : 6s, SDK V10.1 : 40s)
was measured from pressing the "Debug xxx" button in the toolbar
until the debugger reached the (builtin) breakpoint on the first
executable line in main().
I'm running the test with the (builtin) USB cable on an S3E starter kit.

 

Hi Craig,
I cannot find any major differences between the two versions if I do
the following in the XMD console (still within SDK) :
XMD% connect mb mdm
XMD% dow ./SDK_projects/MmController/Debug/mmcontroller.elf

In both version the output in the console appears within 2-3s.

 

Therefore I assume the following :
- Something is wrong in the communication between SDK (Eclipse) and XMD
- The communication between XMD and the target seems OK (and therefore the
  cable and the drivers too).

I've tried the tip from vsiva in the SDK (Eclipse) :
(XMD%) set download-write-size 4096
(XMD%) set remote-memory-write-packet-size 16384
(XMD%) set remote-memory-write-packet-size fixed
Seems that XMD understood the commands but this didn't affect the
download time (still 40s).


Ralf

15,229 Views
Registered: ‎06-02-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hello everybody,

 

I was the one to originate this thread, and I am *so* glad it is coming so alive now after being dormant for a few month.

Hopefully Xilinx will consider it very seriously, now that we see that the tools are hampering any serious debug sessions under 10.1

 

My experience :

o it is dead slow not only with gdb, but with EDK/Eclipse as well.

o slowness is obvious in the download time when compared to a dow under xmd, but what is especially iritating is that, just switching between windows (say from source to registers or local variables) can take 10 or even 20 seconds!!

o when you are reaching a breakpoint, or after a single step, it also takes tens of seconds before you get kbd focus...

o and again, you experience those delays even with Eclipse.

 

I believe that these behaviours rule out any issue with the cables, as I cannot imagine any big traffic happening in those cases.

 

Roland.

 

Xilinx Employee
Xilinx Employee
15,181 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Unfortunately, this seems a bit difficult to reproduce. I tested multiple configurations: Windows/Linux, USB cable/Parallel Cable, MicroBlaze/PPC, but they all seem to work fine. I never see even any delay between switching windows, for instance. Stepping takes a couple of seconds, nowhere close to 10 seconds. I also asked around, and no one else seems to have noticed it as well.

 

Yet, it is obvious that there is some issue, though it might manifest itself in only a few machines/configurations. So the best way to approach this would be to individually work with all of you who are seeing issues via the Xilinx hotline. Please file a webcase, refer to this thread, and provide  as much iinformation as possible, including:

 

- EDK version

- Platform type (Windows, Linux)

- Cable type (USB, Parallel)

- Processor type (PPC405, PPC440 or MicroBlaze)

 

SDK internally uses gdb for everything, so it is not surprising that if you see any issues with gdb, you'll see it with SDK also.

 

Also, try removing the .gdbtkinit file from your home directory, rerun gdb, and see if the issue persists.
0 Kudos
15,145 Views
Registered: ‎09-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi Ralf,

 

It looks like you may have typed "set download-write-size 4096" etc. commands into the XMD window

instead of into the special GDB shell.

 

If you use the GDB (the screen with the red "Tk" icon and "xxx.c - Source Window") 

you need to click  View->Console and open up a GDB console - it will have a white background with a

(gdb)

prompt. You need to type the commands in there.

 

When you are happy with that, create a text file with the commands in it and save it in your project's root directory (along with your .xmp, .mss etc files).

Then you can run the commands from the file by using File->Source from the main GDB window.

**See post #20 for a better solution - the .gdbinit file does this automatically. Windows (XP) will not allow you to rename a file as '.gdbinit' - you will need to use some sort of shell to create/rename a file starting with a '.'.

 

Regards,

Craig

Message Edited by craigwoodhead on 10-08-2008 06:32 PM
0 Kudos
15,101 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi Craig,

thanks for your response.

 

My intention was to try the commands in XMD because

I am developing under Eclipse (but they didn't help either ...)

 

Regards,

  Ralf

 

15,101 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi together,

here's my way to reproduce the "slow download problem" in SDK V10.1.

It took me a while to find a way without any custom module (IP or software).

The project created is using solely Xilinx modules.

I will post this "recipe" to Xilinx via WebCase (in the hope that they

are able to reproduce the problem).

 

- create a new XPS project using BSB wizard
  - create a new design
  - Xilinx Spartan 3E Starter Board Rev D
  - MicroBlaze
  - 50MHz, 50MHz, On-chip HW debug module, 16k BRAM, Cache Enable, no FPU
  - RS232_DTE 9600 8 no parity with interrupt
  - RS232_DCE 9600 8 no parity with interrupt
  - LEDs_8Bit no interrupt
  - DIP_switches_4Bit no interrupt
  - Buttons_4Bit no interrupt
  - FLASH
  - DDR_SDRAM
  - Ethernet_MAC with interrupt
  - Add Peripheral XPS_TIMER 32 bit, one timer, with interrupt
  - 2kB ICache, 2kB DCACHE, ICache + DCache on DDR_SDRAM
  - STDIN STDOUT : RS232_DTE, boot memory ilmb_cntlr
  - Peripheral selftest
  - Peripheral selftest instr. data stack/heap on DDR_SDRAM
- before generating bitstream set in "system assembly view/Addresses" ICache and DCache on mpmc/DDR_SDRAM
- Hardware/generate bitstream

 

- start SDK
- import TestApp_Peripheral
- set optimization level to : No Optimization

- insert the following lines in TestApp_Peripheral.c directly before and after
  main().

 

typedef struct _FillStruct {int Dummy1; int Dummy2;} FILL_STRUCT;
FILL_STRUCT Filler[30000] = {{0},{1}};

int main (void)
{
  Filler[0].Dummy1 = 123;

....
original code
....
}

This will blow up the elf file to about 360kB.

 

- program hardware
- debug testapp_peripheral

 

In V9.2 it takes less than 10s from pressing
the debug button until the debugger is ready.

 

Doing EXACTLY the same in V10.1, it
takes about 72s !!!!!! from pressing
the debug button until the debugger is ready


Development System :
Processor : Dual 2.7GHz AMD Athlon 64 X2 Dual Core 5200+
RAM         : 3GB
OS           : Windows XP Professional 32bit english incl. SP3 and actual Hotfixes
Xilinx SW  : ISEWebPack 10.1 incl. SP3, EDK V10.1 incl. SP3, ISE IP UPDATE 10.1.3

 

 

--Ralf

Explorer
Explorer
14,996 Views
Registered: ‎01-25-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I have exactly the same problems under 10.1 sp3 while debugging.

Note that when I just use the "run" command from Eclipse toolbar everything works as normal and download takes only a second or two.

Hope Xilinx can fix this soon as it has a massive impact on debugging our new design.

Thanks

Lachlan.

Message Edited by lockiegrogan on 10-08-2008 08:14 PM
Lachlan Grogan
CEO, SIL3 Pty Ltd
Melbourne, Australia
http://sil3.com.au
0 Kudos
Xilinx Employee
Xilinx Employee
14,979 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

For SDK users, the best solution is to do the following:

Create a file ".gdbinit" with the following contents:

set download-write-size 4096
set remote memory-write-packet-size 16384

set remote memory-write-packet-size fixed

Place this file in your home directory, or in your application project folder (SDK_Projects/projname).

If you keep it inside your project folder, then the setting will be applicable only for that project. You can follow the same approach when using insight-gdb, but insight-gdb will pick up .gdbinit only from the home directory.

11,801 Views
Registered: ‎09-05-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi together,

the tip from vsiva worked for me !!

 

The download time is now as in V9.2

 

Thanks a lot for the workaround.

 

Ralf

 

 

0 Kudos
Adventurer
Adventurer
11,753 Views
Registered: ‎02-06-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution
I am running SDK 10.1.03. When I click on the Debug icon it takes 33 seconds to launch my design. I have tried creating a .gdbinit text file with the commands mentioned. I have placed this file in both the project folder and the XPS_proj folder. What am I doing wrong?
0 Kudos
Xilinx Employee
Xilinx Employee
11,746 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution
The file has to be in your home directory (preferable), or in your application project folder (SDK_Projects/projname). So I'm not sure what you mean by the project folder or the XPS_proj folder.
0 Kudos
Adventurer
Adventurer
11,742 Views
Registered: ‎02-06-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution
XPS_proj is just a folder where I kepp all my XPS projects (as opposed to ISE only projects). Under XPS_proj I have all my individual projects including my application project folders (SDK_Projects/projname). What is meant by "home" directory?
0 Kudos
Xilinx Employee
Xilinx Employee
11,724 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

On Linux, all users typically have a home directory. On Windows, you can set an environment variable HOME pointing to a specific folder. Make sure it is set by launching a cygwin shell and doing an "echo $HOME" to make sure it is the right place.

0 Kudos
Adventurer
Adventurer
11,713 Views
Registered: ‎02-06-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution
I launched an EDK shell and entered echo $HOME. The result is /cygdrive/c/hfswork/. I have a windows system variable HOME set to c:\hfsswork. I put the file.gdbinit in this directory, but there is still no improvement in speed. Please help.
0 Kudos
Adventurer
Adventurer
11,676 Views
Registered: ‎02-06-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution
Does anyone else have these typical slow "launch" times with SDK 10.1.03? Also updating variables in the global variable watch window is very slow.
0 Kudos
Participant bryan.althouse
Participant
11,344 Views
Registered: ‎12-08-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

I have the same problem.  I have added the Windows environment variable HOME.  It has a path with no spaces (cygwin didn't like: "Documents and Settings").  I have put the .gdbinit file in the HOME directory.  Eclipse still has over 20 seconds of delay per "step over" debug operation.   If I launch the Cygwin propt from SDK (Xilinx Tools->Launch EDK Shell..), and I type:

 

cat $HOME/.gdbinit

 

the response is:

 

set download-write-size 4096

set remote memory-write-packet-size 16384

set remote memory-write-packet-size fixed

 

As far as I can tell, I've followed vsiva's directions, but I have no speed improvement.  Any help is much appreciated.

 

 

Should I be using Linux?  I've done alot of software development on Linux.  For whatever reason, I've always used Windows for Xilinx tools.  I don't mind switching if it would help.

 

Bryan

0 Kudos
Xilinx Employee
Xilinx Employee
11,337 Views
Registered: ‎01-18-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Hi Bryan,

 

There are two separate issues here:

 

1. Download speed (downloading the ELF to the board while launching debug) is slow.  This is a gdb issue, and should be fixed by the 3 gdb settings (download-write-size, etc).

 

2. Stepping is slow. This has been reported by 3 or 4 people on this thread. I don't have the exact steps to reproduce this issue, but from what I've seen, stepping seems to be slow whenever there are variables/expressions/etc in the SDK window that need to be updated after every step. Unfortunately, this seems like an SDK issue that we won't be able to fix until 11.1. You could check if this is the issue by not having any expressions/variables in your view. You could also check if you see a similar slowdown when just using insight-gdb.

 

This particular issue is platform independent. Personally I prefer to use Linux for all development as I find it faster.

0 Kudos
Participant bryan.althouse
Participant
11,325 Views
Registered: ‎12-08-2008

Re: GDB GUI (Insight) *very* slow under Xilinx 10.1 suite

Jump to solution

Vsiva,

 

Thanks for your help.  Closing the variables window did seem to speed up the stepping.  Steps now take 6 to 9 seconds.  It was more like 20.  I'll try the linux tools eventually.

 

Bryan.