UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
4,759 Views
Registered: ‎02-01-2010

GDB: ide_initialize_paths failed

Hello,

I've just installed the complete suite of ISE 12.2 on Windows 7 over a previous installation of ISE 11.4.

 

Now if I try to start the debugger in XPS from the menu "Debug / Launch Software Debugger..." I get the following error in the windows console just before it is quickly closed:

 

ide_initialize_paths failed:Can't find the GUI Tcl library in the following directories:

C:/Xilinx/12.2/ISE_DS/EDK/usr/share/redhat/gui C:/Xilinx/12.2/ISE_DS/EDK/share/redhat/gui/ C:/Xilinx/12.2/ISE_DS/share/redhat/gui C:/Xilinx/12.2/ISE_DS/EDK/insight-gdb/microblaze/nt/libgui/library C:/Xilinx/12.2/ISE_DS/EDK/usr/share/redhat/ide C:/Xilinx/12.2/ISE_DS/EDK/share/redhat/ide C:/Xilinx/12.2/ISE_DS/share/redhat/ide C:/Xilinx/12.2/ISE_DS/EDK/insight-gdb/microblaze/nt/libide/library

 

Can anyone help me to solve this issue?

 

Thanks a lot,

Gianni Valenti

Tags (4)
0 Kudos
4 Replies
Visitor luis.rosado
Visitor
4,707 Views
Registered: ‎02-03-2010

Re: GDB: ide_initialize_paths failed

I have the same problem... Did you find a solution?

 

Thank you in advance.

0 Kudos
4,687 Views
Registered: ‎02-01-2010

Re: GDB: ide_initialize_paths failed

Not yet. I think it's related to the PATH variable, but I don't have the time to investigate further.

 

I also opened a WebCase but a Xilinx engineer suggested me to try SDK debugger instead, because the XPS debugger is not supported any more.

 

If I find a solution I will publish it here.

 

Bye,

Gianni

0 Kudos
Scholar embedded
Scholar
4,080 Views
Registered: ‎06-09-2011

Re: GDB: ide_initialize_paths failed

Hi,

 

I have the same problem, when I want to lunch software debugger I see that it had searched many directories but couldn't find GUI tcl library.

I also tried to export my project to the SDK and lunch software debugger there but I still couldn't find how I can do it in SDK.

I would appreciate any help on this issue.

Something bothers me from Xilinx and that's great & fast changes they make in their software in every release.

All the time I should spend time to learn how to do something in EDK and in later versions I see that they have moved that feature to SDK or somewhere else.

 

Thanks,

Hossein Moradi Sarvandi 

0 Kudos
Newbie bobbaylor
Newbie
4,062 Views
Registered: ‎01-12-2012

Re: GDB: ide_initialize_paths failed

Hi All,

The tcl gui got installed somewhere else on my system. It's probably going to bite me when I update, but I just copied the tcl stuff to one of the locations that mb-gdb is looking. Now it works. 

 

PS: it was a pain to find out what was going wrong because the DOS box would appear and disappear before I could read the error output. I ended up freezing the DOS box with a Ctrl-S and dumping the Win7 process to find the command line invoking it. The command line ended with ;exit which I removed and put the rest into a batch file. Running the batch file, I could finally see the lib path error output.

 

Bob

0 Kudos