cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mattatmdi
Visitor
Visitor
3,221 Views
Registered: ‎09-07-2009

How do you replace cores ?

Hi All,

 

After loading the  ml507_bsb_std_ip_usb_ppc440.zip file , for the ML507

 

I get the following messages below:

 

How do I go about replacing these cores. The example system has a number of periperhals using the old core version.

Do I have to change the version that these periperals are using, and how do I do that ?

 

Thanks in advance.

 

Matt

 

-----messages

The following changes need to be made manually by the user:
 Core xps_gpio 1.00.a needs to be replaced by 2.00.a
 Core xps_mch_emc 2.00.a needs to be replaced by 3.00.a
 Core xps_ll_temac 1.01.b needs to be replaced by 2.02.a
 Core clock_generator 2.01.a needs to be replaced by 3.01.a
 Core xps_intc 1.00.a needs to be replaced by 2.00.a

-----END messages 

0 Kudos
2 Replies
prateek_bhatt
Scholar
Scholar
3,215 Views
Registered: ‎08-21-2008

Hello. 

Seeing the MHS file of your ml507_bsb_std_ip_usb_ppc440.zip you can make a new project in your version. That will remove the message.

Make your project exactly same as the MHS file. 

Best of luck.
--
Unlimited in my Limits.
0 Kudos
alperuzgec
Contributor
Contributor
3,196 Views
Registered: ‎11-23-2008

General solution is;

 

put your new core folder "my_core_2.0"  in your pcores or repository folder. Edit MHS file;

 

BEGIN DRIVER
 PARAMETER DRIVER_NAME = my_core
 PARAMETER DRIVER_VER = 1.00.a
 PARAMETER HW_INSTANCE = blabla

END

 

change 1.00.a to 2.00.a or anyway.

0 Kudos