UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer giorgio.lopez
Observer
8,498 Views
Registered: ‎02-02-2012

How to debug Linux Applications with SDK2015.1 and Zedboard

Hello, I'm currently trying to debug a Linux application on a Zedboard without success. All the guides (including the one regarding SDK 2015.1) refer to the Debug As -> Debug Configuration -> Remote ARM Linux Application mode, which appears to be missing from my version of the SDK (I'm running it under Linux, if that does matter).

 

Any ideas? Is that mode discontinued from the 2014 versions onwards?

 

Thanks a lot

0 Kudos
4 Replies
Scholar stephenm
Scholar
8,490 Views
Registered: ‎05-06-2012

Re: How to debug Linux Applications with SDK2015.1 and Zedboard

Hey,

 

I have created a tutorial targetting 2014.4 (attached) there are steps towardsa the end for Linux debug in SDK

Observer giorgio.lopez
Observer
8,444 Views
Registered: ‎02-02-2012

Re: How to debug Linux Applications with SDK2015.1 and Zedboard

Hello and thanks,

 

I've come across this guide but my situation differs in two point.

 

First of all (I think it's just a matter of version 2015.1 vs 2014.4) when I chose to create a linux project SDK doesn't ask me anymore about the hardware platform project. Secondly, and more importantly, I can't seem to connect to the TCF agent running on my board: the network is properly connected, I can ping the board from my workstation and vice-versa, and the target connection also gets "auto-detected" by the SDK.

Anyway, the debugger will not connect (it will show a connecting... message in the debug view but then it will just hang waiting forever). I checked the petalinux booting procedure on my zedboard console output and i can see "Starting TCF-Agent: OK"

 

 

0 Kudos
Scholar sampatd
Scholar
8,382 Views
Registered: ‎09-05-2011

Re: How to debug Linux Applications with SDK2015.1 and Zedboard

0 Kudos
Scholar stephenm
Scholar
8,354 Views
Registered: ‎05-06-2012

Re: How to debug Linux Applications with SDK2015.1 and Zedboard

This PDF is a bit old. However, the setting up the debugger for linux is still the same in 2015.1. It sounds like you are still using the default connection. this is not what you want to do, you want to connect to the tcf runnign on your board. Are you following the steps on page 28?

 

Also, just to test, can you use the images on the wiki to make sure that the issue isnt with your image?

http://www.wiki.xilinx.com/Zynq+Releases

0 Kudos