cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
365 Views
Registered: ‎04-30-2015

Importing Hardware Specification stays at 0% and never completes

After exporting the hardware/bitstream from Vivado 2016.3 and attempting to import the hardware specification into the 2016.3 SDK, the dialog box stays at 0% and never completes as shown below. The activity indicator in the lower right moves back and forth, however nothing else happens. I tried starting the SDK on its own and creating the new hardware project from the .hdf file but the behavior remains the same. I have also attached .../.metadata/.log for reference. Thank you in advance for your help and suggestions!

The SDK.log file contents (no obvious issues in the log):

07:57:48 INFO : Registering command handlers for SDK TCF services
07:57:48 INFO : Launching XSCT server: xsct -n -interactive /home/rrooyen/Project/novina/LPC_Novina_Dev/Novina_SoC/vivado_xc7z030sbg485-1/Novina_SoC.sdk/temp_xsdb_launch_script.tcl
07:57:49 INFO : XSCT server has started successfully.
07:57:49 INFO : Successfully done setting XSCT server connection channel
07:57:50 INFO : Successfully done setting SDK workspace
07:57:50 INFO : Processing command line option -hwspec /home/rrooyen/Project/novina/LPC_Novina_Dev/Novina_SoC/vivado_xc7z030sbg485-1/Novina_SoC.sdk/Novina_SoC_wrapper.hdf.

The SDK is unziping the archive as expected:

[rrooyen@hancock Novina_SoC.sdk]$ ls Novina_SoC_wrapper_hw_platform_0/
drivers ps7_init_gpl.c ps7_init.html
Novina_SoC_wrapper.bit ps7_init_gpl.h ps7_init.tcl
ps7_init.c ps7_init.h system.hdf

Xilinx SDK 2016.3 - Importing Hardware Spec - freeze.jpg

0 Kudos
2 Replies
Highlighted
Moderator
Moderator
325 Views
Registered: ‎10-06-2016

Re: Importing Hardware Specification stays at 0% and never completes

Hi @rrooyen ,

I would recommend you to modify the Xilinx SDK log level to "Debug" so you can have more insights on what's going on.

Regards


Ibai
Don’t forget to reply, kudo, and accept as solution.
Highlighted
Observer
Observer
311 Views
Registered: ‎04-30-2015

Re: Importing Hardware Specification stays at 0% and never completes

Hi Ibai,

Thank you very much for the reply and I was able to resolve the issue by rebuilding my workstation (Ubuntu 16.04.06 LTS).

Cheers,

Robert

0 Kudos