UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bhuelsen
Visitor
2,506 Views
Registered: ‎06-22-2017

Include Opencv 2.4.11 libraries in Petalinux 2017.2

Hi everyone,

 

my actual petalinux 2017.2 project is dependent to use opencv 2.4.11.

By default opencv 3.x will be fetched if I build the rootfs.

 

I figured out that I can specify the preferred preferred version of opencv in

<PETALINUX_INSTALL_DIR>/components/yocto/source/aarch64/layers/meta-petalinux/conf/distro/petalinux.conf

by modifying

PREFERRED_VERSION_opencv ?= "3.% to PREFERRED_VERSION_opencv ?= "2.% .

 

benjaminh@memory-lab-pc:~/embedded_development/ultrazed_repo/software/petalinux_build$ petalinux-build --component rootfs
#[INFO] building rootfs
[INFO] sourcing bitbake
INFO: bitbake petalinux-user-image -c do_image_complete
Parsing recipes: 100% |##########################################| Time: 0:01:12
Parsing of 2446 .bb files complete (0 cached, 2446 parsed). 3236 targets, 224 skipped, 0 masked, 0 errors.
NOTE: Resolving any missing task queue dependencies
NOTE: preferred version 2.% of opencv not available (for item opencv)
NOTE: versions of opencv available: 3.1+gitAUTOINC+92387b1ef8
NOTE: preferred version 2.% of opencv not available (for item opencv-dev)
NOTE: versions of opencv available: 3.1+gitAUTOINC+92387b1ef8
NOTE: preferred version 2.% of opencv not available (for item opencv-apps)
NOTE: versions of opencv available: 3.1+gitAUTOINC+92387b1ef8
NOTE: preferred version 2.% of opencv not available (for item opencv-dbg)
NOTE: versions of opencv available: 3.1+gitAUTOINC+92387b1ef8
Initialising tasks: 100% |#######################################| Time: 0:00:07
Checking sstate mirror object availability: 100% |###############| Time: 0:00:19

But as you can see version 2.x of opencv is not avialable.

 

How do I have to modify the build system to install opencv 2.4.11?

Tags (3)
0 Kudos
1 Reply
Visitor nicka
Visitor
210 Views
Registered: ‎07-20-2016

Re: Include Opencv 2.4.11 libraries in Petalinux 2017.2

bhuelsen, did you ever figure out how to do this?  I would like to do the same thing using the 2018.3 Petalinx tool chain.

0 Kudos