UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor jbigo12
Visitor
461 Views
Registered: ‎02-13-2019

Invalid command name "configparams"

Jump to solution

Hello everyone,

I am currently working with a Xilinx-Zynq XC7Z010-1CLG400C board and trying to load the hardware configuration via XMD from SDK 2014.3 (I am forced to work with this older version). The issue arises while running the method ps7_post_config.
I will try to describe my steps:

- Create hardware configuration with Vivado 2018.3
- Open XMD:
   XMD% connect arm hw
   XMD% source ../file.tcl
   XMD% ps7_init    (I had to remove all "force" words from the tcl, as discussed here)
   XMD% ps7_post_config
    invalid command name "configparams"

Did anybody face the same or a similar issue? I attach the .tcl file, in case of interest.

Many thanks.

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
420 Views
Registered: ‎10-21-2010

Re: Invalid command name "configparams"

Jump to solution

HI @jbigo12,

You can delete lines 764, 765, 779. configparams command is not supported by XMD

View solution in original post

2 Replies
Highlighted
Xilinx Employee
Xilinx Employee
421 Views
Registered: ‎10-21-2010

Re: Invalid command name "configparams"

Jump to solution

HI @jbigo12,

You can delete lines 764, 765, 779. configparams command is not supported by XMD

View solution in original post

Visitor jbigo12
Visitor
401 Views
Registered: ‎02-13-2019

Re: Invalid command name "configparams"

Jump to solution

Thank you @sadanan. I removed the lines and everything worked out.

0 Kudos